1. 程式人生 > >Constructing Roads(HDU)

Constructing Roads(HDU)

                                      Constructing Roads

 

Problem Description

There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected.

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.

Input

The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.

Output

You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.

Sample Input

3

0 990 692

990 0 179

692 179 0

1

1 2

Sample Output

179

題目連結:

http://acm.hdu.edu.cn/showproblem.php?pid=1102

題意描述:

給你n個村莊,以及他們之間的修路所需要的錢,其中有m個村莊的路已經修好了,問把這些村莊都連起來,所需的最小修路費用

解題思路:

先建一個圖,然後就是最小生成樹的模板了

程式程式碼:

#include<stdio.h>
#include<string.h>
#define inf 99999999
int e[110][110],book[110],dis[110];
int n;
int prime();

int main()
{
	int i,j,m,t,a,b;
	while(scanf("%d",&n)!=EOF)
	{
		for(i=1;i<=n;i++)
			for(j=1;j<=n;j++)
			{
				scanf("%d",&m);
				e[i][j]=m;
			}
		scanf("%d",&t);
		for(i=1;i<=t;i++)
		{
			scanf("%d%d",&a,&b);
			e[a][b]=e[b][a]=0;
		}
											
		for(i=1;i<=n;i++)
			dis[i]=e[1][i];
		memset(book,0,sizeof(book));
		book[1]=1;
		m=prime();
		printf("%d\n",m);
	}
	return 0;
}
int prime()
{
	int sum=0,i,u,min,k;
	for(k=1;k<n;k++)
	{
		min=inf;
		for(i=1;i<=n;i++)
			if(book[i]==0&&dis[i]<min)
			{
				min=dis[i];
				u=i;
			}
		book[u]=1;
		sum+=dis[u];
		for(i=1;i<=n;i++)
			if(book[i]==0&&dis[i]>e[u][i])
				dis[i]=e[u][i];
	}
	return sum;
}