1. 程式人生 > >hdoj 1010 奇偶剪枝

hdoj 1010 奇偶剪枝

奇偶剪枝,顧名思義,是一種剪枝方式,一般搜尋中用到。就是在一個矩陣裡面,給定起始點與終止點,然後給定一個步數能否在這個步數走到終點,這就用到了奇偶剪枝,奇偶剪枝的意思就是兩個座標的絕對距離如果要是奇數(偶數),那麼無論怎麼走步數仍然是奇數(偶數)。

例題是hdoj的1010 Tempter of the Bone

這個題目就充分利用了奇偶剪枝。

題意如下:

Tempter of the Bone

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 146221    Accepted Submission(s): 38985



 

Problem Description

The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.

Input

The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

'X': a block of wall, which the doggie cannot enter;
'S': the start point of the doggie;
'D': the Door; or
'.': an empty block.

The input is terminated with three 0's. This test case is not to be processed.

Output

For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.

Sample Input

4 4 5

S.X.

..X.

..XD

....

3 4 5

S.X.

..X.

...D

0 0 0

Sample Output

NO

YES

程式碼如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <queue>
using namespace std;
int n,m,t;
char Map[10][10];
int is[10][10];
int loc[4][2]={{-1,0},{1,0},{0,1},{0,-1}};
struct ss
{
    int t;
    int x,y;
};
int stt,sdd,et,ed;
int flag=0;
void dfs (int st,int sd,int time)
{
    //is[st][sd]=1;
    if(time>=t&&Map[st][sd]!='D')
        return;

    if(Map[st][sd]=='D'&&time==t)
    {
        flag=1;
        //printf("YES\n");
        return;
    }

    if(t-time-abs(st-et)-abs(sd-ed)<0)
        return;
    int x,y;
    for (int i=0;i<4;i++)
    {
        x=st+loc[i][0];
        y=sd+loc[i][1];
        if(x>=0&&x<n&&y>=0&&y<m&&!is[x][y]&&Map[x][y]!='X')
        {
            is[x][y]=1;
            dfs (x,y,time+1);
            if(flag)
                return;
            is[x][y]=0;
        }
        if(flag)
            return;
    }
}
int main()
{
    while (scanf("%d%d%d",&n,&m,&t)!=EOF&&(n||m||t))
    {
        flag=0;
        memset (is,0,sizeof(is));
        for (int i=0;i<n;i++)
            for (int j=0;j<m;j++)
               {
                   cin>>Map[i][j];
                   if(Map[i][j]=='S')
                   {
                       stt=i;
                       sdd=j;
                   }
                   if(Map[i][j]=='D')
                   {
                       et=i;
                       ed=j;
                   }
               }
        if((abs(stt-et)+abs(sdd-ed))%2==t%2)
        {
                is[stt][sdd]=1;
                dfs(stt,sdd,0);
        }
        if(flag)
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}