1. 程式人生 > >01揹包問題 hdu2602 Bone Collector

01揹包問題 hdu2602 Bone Collector

Bone Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 61944    Accepted Submission(s): 25823


Problem Description Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?


Input The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
Output One integer per line representing the maximum of the total value (this number will be less than 231
).
Sample Input 1 5 10 1 2 3 4 5 5 4 3 2 1
Sample Output 14
Author Teddy
Source
Recommend lcy   |   We have carefully selected several similar problems for you:  1203 2159 2955 1171 2191  思路     就是01揹包問題 程式碼:
import java.util.*;
public class pack {

	/**
	 * @param args
	 */
	public static int bag(int m,int w,int weight[],int value[],int c[][])
	{
		
		for(int i=1;i<=m;i++)
		{
			for(int j=0;j<=w;j++)
			{
				if(weight[i]<=j)
				{
					if((c[i-1][j-weight[i]]+value[i])>c[i-1][j])
						c[i][j]=c[i-1][j-weight[i]]+value[i];
					else
						c[i][j]=c[i-1][j];
				}
				else
					c[i][j]=c[i-1][j];
			}
		}
		return c[m][w];
	}
	public static void main(String[] args) {
		// TODO Auto-generated method stub
		Scanner in=new Scanner(System.in);
		int n=in.nextInt();
		for(int i=0;i<n;i++)
		{
			int m=in.nextInt();
			int w=in.nextInt();
			int weight[]=new int[m+1];
			int value[]=new int[m+1];
			int c[][]=new int[m+1][w+1];
			for(int j=0;j<m;j++)
				value[j+1]=in.nextInt();
			for(int j=0;j<m;j++)
				weight[j+1]=in.nextInt();
			System.out.println(bag(m,w,weight,value,c));
		}
	}

}