1. 程式人生 > 實用技巧 >POJ 3579 Drying (二分答案)

POJ 3579 Drying (二分答案)

題目

It is very hard to wash and especially to dry clothes in winter. But Jane is a very smart girl. She is not afraid of this boring process. Jane has decided to use a radiator to make drying faster. But the radiator is small, so it can hold only one thing at a time.

Jane wants to perform drying in the minimal possible time. She asked you to write a program that will calculate the minimal time for a given set of clothes.

There are n clothes Jane has just washed. Each of them took ai water during washing. Every minute the amount of water contained in each thing decreases by one (of course, only if the thing is not completely dry yet). When amount of water contained becomes zero the cloth becomes dry and is ready to be packed.

Every minute Jane can select one thing to dry on the radiator. The radiator is very hot, so the amount of water in this thing decreases by k this minute (but not less than zero — if the thing contains less than k water, the resulting amount of water will be zero).

The task is to minimize the total time of drying by means of using the radiator effectively. The drying process ends when all the clothes are dry.

Input
The first line contains a single integer n (1 ≤ n ≤ 100 000). The second line contains ai separated by spaces (1 ≤ ai ≤ 109). The third line contains k (1 ≤ k ≤ 109).

Output
Output a single integer — the minimal possible number of minutes required to dry all clothes.

Sample Input
sample input #1
3
2 3 9
5

sample input #2
3
2 3 6
5
Sample Output
sample output #1
3

sample output #2
2

題解

經經典點二分題,就是我們二分洗衣服的時間,這個很容易想。但是這題好像也很容易t,所以我們在check函式裡面如果每次暴力模擬操作就可能是超時的。所以我們小優化一下,就每個物品無論如何最少減t,然後判斷剩下的能不能被t次的k-1烘乾就好了,這樣只需要掃一遍。

程式碼實現

#include<cstdio>
#include<iostream>
#include<cmath>
#include<cstring>
#include<algorithm>
#include<vector>
using namespace std;
const int maxn=1e5+10;
typedef long long ll;
typedef pair<int,int> PII;
using namespace std;
ll n,m,k;
vector <ll> v;

bool check (ll mid) {
  ll temp=mid;
  for (int i=0;i<v.size ();i++) {
    if (v[i]-mid>0) temp-=(ll)ceil ((double)(v[i]-mid)/(k-1));
    if (temp<0) return false; 
  }
  return true;
}

int main () {
  ios::sync_with_stdio (false);
    cin>>n;
    v.clear ();
    ll x;
    for (int i=1;i<=n;i++) {
      cin>>x;
      v.push_back (x);
    }
    cin>>k;
    ll st=*max_element (v.begin (),v.end ());
    ll l=1,r=st;
    while (l<r) {
      int mid=(l+r)>>1;
      if (check (mid)) r=mid;
      else l=mid+1;
    }
    printf ("%lld\n",l);
  
  return 0;
}