1. 程式人生 > 實用技巧 >還是暢通工程(最小生成樹 並查集 Prim Kruskal)

還是暢通工程(最小生成樹 並查集 Prim Kruskal)

Description

某省調查鄉村交通狀況,得到的統計表中列出了任意兩村莊間的距離。省政府“暢通工程”的目標是使全省任何兩個村莊間都可以實現公路交通(但不一定有直接的公路相連,只要能間接通過公路可達即可),並要求鋪設的公路總長度為最小。請計算最小的公路總長度。

Input

測試輸入包含若干測試用例。每個測試用例的第1行給出村莊數目N ( < 100 );隨後的N(N-1)/2行對應村莊間的距離,每行給出一對正整數,分別是兩個村莊的編號,以及此兩村莊間的距離。為簡單起見,村莊從1到N編號。
當N為0時,輸入結束,該用例不被處理。

Output

對每個測試用例,在1行裡輸出最小的公路總長度。

Sample Input

3
1 2 1
1 3 2
2 3 4
4
1 2 1
1 3 4
1 4 1
2 3 3
2 4 2
3 4 5
0

Sample Output

3
5
#include <iostream>
#include <algorithm>

using namespace std;

struct Node
{
    int a;
    int b;
    int dis;
};

int father[101];
Node node[5100];

bool cmp(Node A, Node B)
{
    return A.dis < B.dis;
}

int Find(int t)
{
    int temp = t;
    while (temp != father[temp])
        temp = father[temp];
    return father[t] = temp;
}

int main()
{
    ios::sync_with_stdio(false);
    cin.tie(NULL);
    cout.tie(NULL);

    int n, m;
    while (cin >> n && n != 0)
    {
        for (int i = 1; i <= n; ++i)
            father[i] = i;
        m = n * (n - 1) / 2;
        for (int i = 0; i < m; ++i)
            cin >> node[i].a >> node[i].b >> node[i].dis;
        sort(node, node + m, cmp);

        int ans = 0, cnt = 0;
        for (int i = 0; i < m; ++i)
        {
            int a = Find(node[i].a);
            int b = Find(node[i].b);
            if (a != b)
            {
                ans += node[i].dis;
                cnt++;
                father[b] = a;
                if (cnt == n - 1)
                    break;
            }
        }
        cout << ans << endl;
    }
    return 0;
}
#include <stdio.h>
#include <stdlib.h>
#include <string.h>

int arc[100][100];
int V[100];

int ans, n;

int ok()
{
	for (int i = 0; i < n; i++)
		if (V[i] == 0)
			return 1;
	return 0;
}

void solve()
{
	int shortPath[100];
	int t = 0, i, j, min;

	memset(shortPath, 0x7f, sizeof(shortPath));
	memset(V, 0, sizeof(V));
	ans = 0;

	while (ok())
	{
		V[t] = 1;
		for (i = 0; i < n; i++)
			if (arc[t][i] > 0 && V[i] == 0 && arc[t][i] < shortPath[i])
				shortPath[i] = arc[t][i];
		min = 0;
		for (i = 1; i < n; i++)
			if (shortPath[min] > shortPath[i] && shortPath[i] != 0)
				min = i;
		if (min != 0)
		{
			ans += shortPath[min];
			t = min;
			shortPath[min] = 0;
		}
	}
}

int main()
{
	int m, i;
	int v1, v2, w;
	while (~scanf("%d", &n) && n)
	{
		memset(arc, 0, sizeof(arc));
		m = n * (n - 1) / 2;
		while(m--)
		{
			scanf("%d%d%d", &v1, &v2, &w);
			arc[v1 - 1][v2 - 1] = w;
			arc[v2 - 1][v1 - 1] = w;
		}
		solve();
		printf("%d\n", ans);
	}
	return 0;
}