1. 程式人生 > 其它 >stack《==》 先序和中序

stack《==》 先序和中序

技術標籤:mooc資料結構

03-樹3Tree Traversals Again(25分)

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.


Figure 1

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integerN(≤30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 toN). Then2Nlines follow, each describes a stack operation in the format: "Push X" where X is the index of the node being pushed onto the stack; or "Pop" meaning to pop one node from the stack.

Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop

Sample Output:

3 4 2 6 5 1

這個題,利用stack 非遞迴實現了,先序和中序

push操作得到的是先序遍歷

pop操作給定的是中序遍歷(畫個圖就明白了。。。)

那麼題目就變成了根據先序和中序輸出後序

可以複習下 先序中序得到後序遍歷

#include <iostream>
#include <stack>
using namespace std;
#define Max 100
//給定push 操作得到的是先序遍歷
// pop 操作給定的是中序遍歷
//那麼題目就變成了根據先序和中序輸出後序
int pre[Max];
int in[Max];
int post[Max];
void solve(int prel, int inl, int postl, int n) {
  if (n == 0) return;
  if (n == 1) {
    post[postl] = pre[prel];
    return;
  }
  int i;
  int root = pre[prel];
  post[postl + n - 1] = root;  //那麼根節點就是後序遍歷的最後一個
  for (i = 0; i < n; i++)
    if (in[inl + i] == root) break;
  int L = i;
  int R = n - L - 1;
  //分別遞迴左右子樹
  solve(prel + 1, inl, postl, L);
  solve(prel + L + 1, inl + L + 1, postl + L, R);
}

int main() {
  int n;
  stack<int> sta;
  scanf("%d\n", &n);
  int j = 0, k = 0;
  for (int i = 0; i < 2 * n; i++) {
    string s;
    cin >> s;
    int x;
    if (s == "Push") {
      cin >> x;
      sta.push(x);
      pre[j++] = x;
    } else {
      in[k++] = sta.top();  
      sta.pop();
    }
  }
  solve(0, 0, 0, n);
  for (int m = 0; m < n; m++) {
    if (m != 0)
      printf(" %d", post[m]);
    else
      printf("%d", post[m]);
  }
  return 0;
}