1. 程式人生 > 其它 >【注意點分析】1016 Phone Bills (25 分)

【注意點分析】1016 Phone Bills (25 分)

技術標籤:PAT甲級PATPAT甲級

立志用最少的程式碼做最高效的表達


PAT甲級最優題解——>傳送門


A long-distance telephone company charges its customers by the following rules:

Making a long-distance call costs a certain amount per minute, depending on the time of day when the call is made. When a customer starts connecting a long-distance call, the time will be recorded, and so will be the time when the customer hangs up the phone. Every calendar month, a bill is sent to the customer for each minute called (at a rate determined by the time of day). Your job is to prepare the bills for each month, given a set of phone call records.

Input Specification:
Each input file contains one test case. Each case has two parts: the rate structure, and the phone call records.

The rate structure consists of a line with 24 non-negative integers denoting the toll (cents/minute) from 00:00 - 01:00, the toll from 01:00 - 02:00, and so on for each hour in the day.


The next line contains a positive number N (≤1000), followed by N lines of records. Each phone call record consists of the name of the customer (string of up to 20 characters without space), the time and date (MM:dd:HH:mm), and the word on-line or off-line.

For each test case, all dates will be within a single month. Each on-line record is paired with the chronologically next record for the same customer provided it is an off-line record. Any on-line records that are not paired with an off-line record are ignored, as are off-line records not paired with an on-line record. It is guaranteed that at least one call is well paired in the input. You may assume that no two records for the same customer have the same time. Times are recorded using a 24-hour clock.

Output Specification:
For each test case, you must print a phone bill for each customer.

Bills must be printed in alphabetical order of customers’ names. For each customer, first print in a line the name of the customer and the month of the bill in the format shown by the sample. Then for each time period of a call, print in one line the beginning and ending time and date (dd:HH:mm), the lasting time (in minute) and the charge of the call. The calls must be listed in chronological order. Finally, print the total charge for the month in the format shown by the sample.

Sample Input:
10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10
10
CYLL 01:01:06:01 on-line
CYLL 01:28:16:05 off-line
CYJJ 01:01:07:00 off-line
CYLL 01:01:08:03 off-line
CYJJ 01:01:05:59 on-line
aaa 01:01:01:03 on-line
aaa 01:02:00:01 on-line
CYLL 01:28:15:41 on-line
aaa 01:05:02:24 on-line
aaa 01:04:23:59 off-line

Sample Output:
CYJJ 01
01:05:59 01:07:00 61 $12.10
Total amount: $12.10
CYLL 01
01:06:01 01:08:03 122 $24.40
28:15:41 28:16:05 24 $3.85
Total amount: $28.25
aaa 01
02:00:01 04:23:59 4318 $638.80
Total amount: $638.80


注意

如果某一個人雖然有賬單,但是沒有找到有效的通話記錄,這個人不予輸出

輸入的一天內各個小時段的話費單位是美分/分鐘,所以在計算的時候一個小時的話費應該是60*price[i],另外輸出費用要按美元計算,所以要除以100,不妨在輸入一天內各個小時段的話費時就直接進行除以100的操作

輸出月、日、時、分都必須有兩位數字不夠的要在高位補0


#include<bits/stdc++.h>
using namespace std;
struct Time{//定義時間類
    int month,day,hour,minute,time,online=0;//月日時分資訊、距0日0時0分的分鐘數、指明這一時間是online還是offline
    bool operator <(const Time&t)const{//過載<運算子
        return this->time<t.time;
    }
};
double price[25];//儲存一天內各個小時段的話費單位是美元/分鐘
double compute(Time t,int day){//計算當前時間到day日0時0分所用話費
    double bill=0.0;
    for(int i=0;i<t.hour;++i)
        bill+=60*price[i];
    return bill+t.minute*price[t.hour]+price[24]*60*(t.day-day);
}
int main(){
    for(int i=0;i<24;++i){//讀取一天內各個小時段的話費
        scanf("%lf",&price[i]);
        price[i]/=100.0;//化為美元
        price[24]+=price[i];
    }
    int N;
    scanf("%d",&N);
    map<string,set<Time>>bill;//儲存每個人的名字和對應的話費時間
    for(int i=0;i<N;++i){//讀取賬單
        string s1,s2;
        Time t;
        cin>>s1;
        scanf("%d:%d:%d:%d",&t.month,&t.day,&t.hour,&t.minute);
        t.time=(t.day*24+t.hour)*60+t.minute;
        cin>>s2;
        if(s2=="on-line")
            t.online=1;
        bill[s1].insert(t);
    }
    for(auto i=bill.cbegin();i!=bill.cend();++i){//查詢有效的話費記錄並就算用時與話費並輸出
        bool output=false;//該人的話費記錄是否需要輸出/是否有有效的話費記錄
        double sumBill=0.0;//該人的話費總額
        for(auto j=(i->second).cbegin();j!=(i->second).cend();++j){//定義set的迭代器j
            auto jnext=j;//定義指向j指向的下一個物件的迭代器
            ++jnext;
            for(;jnext!=(i->second).cend()&&!(j->online&&!jnext->online);++j,++jnext);//查詢有效的話費記錄
            if(jnext!=(i->second).cend()){//如果查詢到了
                if(!output){//還沒有輸出過姓名的月份進行輸出,並通過修改output變數標明該人的話費記錄需要輸出
                    output=true;
                    printf("%s %02d\n",(i->first).c_str(),j->month);
                }
                printf("%02d:%02d:%02d %02d:%02d:%02d ",j->day,j->hour,j->minute,jnext->day,jnext->hour,jnext->minute);//輸出話費賬單起止時間
                int t=jnext->time-j->time;//計算話費
                double bill=compute(*jnext,j->day)-compute(*j,j->day);//計算話費賬單用時
                sumBill+=bill;//加到話費總額上
                printf("%d $%.2f\n",t,bill);//輸出
            }
        }
        if(output)//如果該人的話費記錄需要輸出,輸出話費總額
            printf("Total amount: $%.2f\n",sumBill);
    }
    return 0;
}

耗時

在這裡插入圖片描述


痛苦難道是白忍受的嗎?它應該使我偉大!       ——托馬斯 • 曼