1. 程式人生 > 其它 >hdu-1050 Moving Tables(貪心法)

hdu-1050 Moving Tables(貪心法)

技術標籤:hdu/poj

Moving Tables

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 52571 Accepted Submission(s): 17125

Problem Description
The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure.
在這裡插入圖片描述

The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving.

在這裡插入圖片描述

For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager’s problem.

Input
The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case begins with a line containing an integer N , 1<=N<=200 , that represents the number of tables to move. Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t (each room number appears at most once in the N lines). From the N+3-rd line, the remaining test cases are listed in the same manner as above.

Output
The output should contain the minimum time in minutes to complete the moving, one per line.

Sample Input

3 
4 
10 20 
30 40 
50 60 
70 80 
2 
1 3 
2 200 
3 
10 100 
20 80 
30 50 

Sample Output

10
20
30

題意

一家ACM公司要改革,需要在房間之間移動桌子,可是走廊太狹窄,每次只能移動一張桌子,每10分鐘內,同一段走廊只能移動一張桌子。經理列出了可行和不可行的情況,不可行也就是佔用同一段走廊的情況,如上表。
現在給你N行,每行代表一張桌子的移動路線(從room s到room t),問至少需要多少分鐘可以完成所有桌子的移動。

分析

該樓有400個房間,每兩個房間共享一條走廊,共200條走廊。通過分析可以知道,要求出最少完成時間,我們只需要看被走重複次數最多的走廊即可。用它的次數乘以10就可以得出答案。比如測試用例3,30號房間到50號房間這段走廊被佔用了3次,所以需要30分鐘。

程式碼

#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
const int MAXN = 201;
int crd[MAXN];//一共400間房,共200條走廊 
int main()
{
	//freopen("data.txt","r",stdin);
	int t;
	scanf("%d",&t);
	while(t--){
		memset(crd,0,sizeof(crd));
		int ans=0,n;
		scanf("%d",&n);
		int from,to;
		for(int i=0;i<n;i++){
			scanf("%d %d",&from,&to);
			//小房間號在前 
			if(from>to){
				int t=from;
				from=to;
				to=t;
			}
			//算出房間號對應的走廊編號 
			from=(from+1)/2;
			to=(to+1)/2; 
			for(int i=from;i<=to;i++){
				crd[i]++;
			//ans每次都選重複走次數最多的走廊 
				ans=max(crd[i],ans);
			}
	   }
	   printf("%d\n",ans*10);
	}
	return 0;
}