1. 程式人生 > 其它 >字串統計

字串統計

技術標籤:字串字串演算法

對於給定的一個字串,統計其中數字字元出現的次數。

Input

輸入資料有多行,第一行是一個整數n,表示測試例項的個數,後面跟著n行,每行包括一個由字母和數字組成的字串。

Output

對於每個測試例項,輸出該串中數值的個數,每個輸出佔一行。

Sample Input

2
asdfasdf123123asdfasdf
asdf111111111asdfasdfasdf

Sample Output

6
9

思路:

把一串字元輸入到字串陣列中。

再用for在字串陣列中判斷每個數是否在0~9之間。

#include<stdio.h>  
#include<string.h>  
int main()  
{  
    int n,sum,i;  
    char a[1010]; 
    scanf("%d",&n);
    while(n--)  
    {     
        getchar();  
        scanf("%s",a);  
        sum= 0;  
        for(i = 0;a[i] != '\0';i ++)  
        {  
            if(a[i] >='0' && a[i] <= '9')  
            sum++;  
        }  
        printf("%d\n",sum);  
    }  
    return 0;  
}

注意:

1.getchar(); 別忘了!!!

2.a[i]!='\0'

祝大家新年快樂[]~( ̄▽ ̄)~*