1. 程式人生 > 資訊 >世界造船界皇冠上的明珠,中國首制大型郵輪今日全船貫通

世界造船界皇冠上的明珠,中國首制大型郵輪今日全船貫通

1. 題目

Look-and-say sequence is a sequence of integers as the following:

D, D1, D111, D113, D11231, D112213111, ...

where D is in [0, 9] except 1. The (n+1)st number is a kind of description of the nth number. For example, the 2nd number means that there is one D in the 1st number, and hence it is D1

; the 2nd number consists of one D (corresponding to D1) and one 1 (corresponding to 11), therefore the 3rd number is D111; or since the 4th number is D113, it consists of one D, two 1's, and one 3, so the next number must be D11231. This definition works for D = 1 as well. Now you are supposed to calculate the Nth number in a look-and-say sequence of a given digit D
.

Input Specification:

Each input file contains one test case, which gives D (in [0, 9]) and a positive integer N (≤ 40), separated by a space.

Output Specification:

Print in a line the Nth number in a look-and-say sequence of D.

Sample Input:

1 8

Sample Output:

1123123111

2. 題意

外觀數列,如下案例:

D, D1, D111, D113, D11231...

其中D是一個[0, 9]範圍內不等於1的整數;

數列第2項:表示第1項有1個D,所以為D1

數列第3項:表示第2項中有1個1和1個D,所以為D111

數列第4項:表示第3項中有1個D和3個1,所以為D113

數列第5項:表示第4項中有1個D,2個1和1個3,所以為D11231

...

數列第n項:...

題目要求求解給定數字D的外觀數列的第n項。

3. 思路

外觀數列變換: 根據題意,每次新的外觀數列是對上一次外觀數列的一次變換。

變化規則:即對上一個外觀數列字串中的連續字元進行計數,並將字元和字元個數合併成新的字串即為新的外觀數列。

4. 程式碼

#include <iostream>
#include <string>

using namespace std;

string res;

void lookAndSay()
{
	char ch = res[0];
	string temp = "";
	int cnt = 1;
	for (int i = 1; i < res.length(); ++i)
	{
		if (res[i] == ch)
		{
			// 計數連續相等字元的個數 
			cnt++;
		} else
		{
			// 當出現字元不一致時,計數結束,並將字元和個數加入結果temp字串 
			temp += ch + to_string(cnt);
			ch = res[i];
			cnt = 1;
		}
	}
	// 字串最後一位沒有進行計數操作,額外進行一次操作 
	temp += ch + to_string(cnt);
	// 將最新外觀數列temp賦值給res 
	res = temp;
}

int main()
{
	int n;
	cin >> res >> n;
	// 外觀數列的第一項即為本身,不需要進行額外計算 
	n -= 1;	
	while (n--)
	{
		lookAndSay();
	}
	cout << res << endl;
	return 0;
}