1. 程式人生 > 其它 >python3下PyCrypto報錯

python3下PyCrypto報錯

1. 題目

With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.

Chinese Football Lottery provided a "Triple Winning" game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results -- namely W for win, T for tie, and L for lose. There was an odd assigned to each result. The winner's odd would be the product of the three odds times 65%.

For example, 3 games' odds are given as the following:

 W    T    L
1.1  2.5  1.7
1.2  3.1  1.6
4.1  1.2  1.1

To obtain the maximum profit, one must buy W for the 3rd game, T for the 2nd game, and T for the 1st game. If each bet takes 2 yuans, then the maximum profit would be (4.1×3.1×2.5×65%−1)×2=39.31 yuans (accurate up to 2 decimal places).

Input Specification:

Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to W, T and L.

Output Specification:

For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.

Sample Input:

1.1 2.5 1.7
1.2 3.1 1.6
4.1 1.2 1.1

Sample Output:

T T W 39.31

2. 題意

題目一大段的,其實就是找出三個數中的最大值,最大值對應的輸贏情況需要輸出出來,三組資料的最大值需要相乘後代入題目給的公式即可。

3. 思路——簡單模擬

三組資料,每組資料三個數,需要找出三個數中的最大值,if條件句判斷其中一個數均大於或等於其餘兩個數即為最大值。三組數的最大值找到並輸出最大值對應的輸贏情況,並將三個最大值相乘後的值代入公式即可。

4. 程式碼

#include <iostream>

using namespace std;
    
int main()
{
    double sum = 1;
    double x, y, z;
    string s = "";
    for (int i = 0; i < 3; ++i)
    {
        cin >> x >> y >> z;
        // 判斷三個數中的最大值,最大值與sum相乘,並輸出最大值對應的情況 
        if (x >= y && x >= z) sum *= x, s += "W ";
        else if (y >= x && y >= z) sum *= y, s += "T ";
        else sum *= z, s += "L ";
    }
    cout << s;
    // 根據題目所給公式計算即可 
    printf("%.2lf", (sum * 0.65 - 1) * 2);
    return 0;
}