1. 程式人生 > 其它 >面向物件程式設計實驗一

面向物件程式設計實驗一

1. 題目

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N

, followed by N positive numbers. All the numbers in the input are less than 100.

Output Specification:

For each test case, print the total time on a single line.

Sample Input:

3 2 3 1

Sample Output:

41

2. 題意

電梯上升一層需6秒,每層停止5秒,下降一層需4秒,計算電梯在層數之間移動所花費的時間。

3. 思路——簡單模擬

根據題意模擬計算即可 。

4. 程式碼

#include <iostream>

using namespace std;

int main()
{
    int n;
    cin >> n;
    int b = 0;
    int x;
    int sum = 0;
    // 根據題意:電梯上升一層需6秒,每層停止5秒,下降一層需4秒 ,模擬計算即可 
    for (int i = 0; i < n; ++i)
    {
        cin >> x;
        if (x - b > 0) sum += (x - b) * 6 + 5;
        else sum += (b - x) * 4 + 5;
        b = x;
    }
    cout << sum << endl;
    return 0;
}