1. 程式人生 > 資訊 >大屏定製 + 小元件復興,Android 12 正式版亮點導覽

大屏定製 + 小元件復興,Android 12 正式版亮點導覽

原題連結:https://vjudge.net/problem/POJ-3087#author=wuyang1002431655

Problem Description:

A common pastime for poker players at a poker table is to shuffle stacks of chips. Shuffling chips is performed by starting with two stacks of poker chips, S1 and S2, each stack containing C chips. Each stack may contain chips of several different colors.

The actual shuffle operation is performed by interleaving a chip from S1 with a chip from S2 as shown below for C = 5:

The single resultant stack, S12, contains 2 * C chips. The bottommost chip of S12 is the bottommost chip from S2. On top of that chip, is the bottommost chip from S1. The interleaving process continues taking the 2nd chip from the bottom of S2 and placing that on S12, followed by the 2nd chip from the bottom of S1 and so on until the topmost chip from S1 is placed on top of S12.

After the shuffle operation, S12 is split into 2 new stacks by taking the bottommost C chips from S12 to form a new S1 and the topmost C chips from S12 to form a new S2. The shuffle operation may then be repeated to form a new S12.

For this problem, you will write a program to determine if a particular resultant stack S12 can be formed by shuffling two stacks some number of times.

Input:

The first line of input contains a single integer N, (1 ≤ N ≤ 1000) which is the number of datasets that follow.

Each dataset consists of four lines of input. The first line of a dataset specifies an integer C, (1 ≤ C ≤ 100) which is the number of chips in each initial stack (S1 and S2). The second line of each dataset specifies the colors of each of the C chips in stack S1, starting with the bottommost chip. The third line of each dataset specifies the colors of each of the C chips in stack S2 starting with the bottommost chip. Colors are expressed as a single uppercase letter (A through H). There are no blanks or separators between the chip colors. The fourth line of each dataset contains 2 * C uppercase letters (A through H), representing the colors of the desired result of the shuffling of S1 and S2 zero or more times. The bottommost chip’s color is specified first.

Output:

Output for each dataset consists of a single line that displays the dataset number (1 though N), a space, and an integer value which is the minimum number of shuffle operations required to get the desired resultant stack. If the desired result can not be reached using the input for the dataset, display the value negative 1 (−1) for the number of shuffle operations.

Sample Input:

2
4
AHAH
HAHA
HHAAAAHH
3
CDE
CDE
EEDDCC

Sample Output:

1 2
2 -1

解題思路:

模擬題,不斷進行洗牌,洗一次就對該情況標記,若一直洗到再次遇到該標記,則說明重複了,不會得到結果輸出-1,若未遇到重複標記就完成目標,則輸出計數器

AC程式碼:

#include<iostream>
#include<string>
#include<map>
#include<algorithm>
using namespace std;
int main()
{
	int a;								//一共測試資料組數
	cin >> a;
	int num = 1;							//測試資料組數
	map<string, bool>p;					        //定義map p
	for (num; num <= a; num++)
	{	
		p.clear();						//清空map
		int n;
		cin >> n;						//s1,s2字元數
		string s1,s2,S;
		cin >> s1 >> s2 >> S;
		int count = 0;					        //計數器
		while (1)						//進行無限洗牌
		{
			count++;					//迴圈一次計數器+1
			string str;					//每次迴圈對str重新定義
			for (int i = 0; i < n; i++)
			{
				str += s2[i];
				str += s1[i];
			}						//洗牌,s2先洗
			if (p[str] && str!=S)			        //當該次洗完的str在p中對應鍵值為true說明重複,計數器為-1,退出迴圈
			{
				count = -1;
				break;									
			}
			else if (str == S)				//若洗完等於S,退出迴圈
					break;
			p[str] = true;					//將每次洗完的str放進map並賦值true;
			s1 = str.substr(0, str.size() / 2);		//將洗完的牌分成兩組,進行下一次洗牌
			s2 = str.substr(str.size() / 2, str.size());
		}
		cout << num << ' ' << count << endl;
	}
	return 0;
}