1. 程式人生 > 其它 >簡單佇列模式(Queue)

簡單佇列模式(Queue)

原題連結:http://acm.hdu.edu.cn/showproblem.php?pid=1241

Problem Description:

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input:

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either '*', representing the absence of oil, or '@', representing an oil pocket.

Output:

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input:

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

Sample Output:

0
1
2
2

解題思路:

dfs,將搜過的油田填上

AC程式碼:

#include<iostream>
#include<stdio.h>
using namespace std;

char grid[110][110];
int n, m;						//主副函式都要使用

int p(int i, int j)					//判斷陣列是否越界
{
	if (i < 0 || i >= n || j < 0 || j >= m)				
		return 0;
	else
		return 1;
}
int check(int x, int y)
{
	grid[x][y] = '*';				//判斷周圍八個格子是否為油
	for (int dx = -1; dx <= 1; ++dx)
	{
		for (int dy = -1; dy <= 1; ++dy)
		{
			if (grid[x + dx][y + dy] == '@' &&  p(x + dx,y + dy)==1 )
				check(x + dx, y + dy);
		}
	}
	return 0;
	
}
int main ( )
{	
	while ( scanf_s("%d %d", &n, &m) != EOF)
	{
		int sum = 0;
		if (n == 0 && m == 0)		
			break;				//n和m都等於0時輸入結束

		for (int i = 0; i < n; i++) 
		{
			for (int j = 0; j < m; j++)
			{
				cin >> grid[i][j];	//將油田網格輸入grid
			}
		}

		for (int i = 0; i < n; i++)
		{
			for (int j = 0; j < m; j++)	//遍歷grid陣列
			{
				if (grid[i][j] == '@')	//判斷是否為油
				{
					check(i, j);	//是油進行檢查周圍的油田網格
					sum++;
				}
			}
		}
		cout << sum<<endl;
	}
	return 0;
}