1. 程式人生 > 實用技巧 >HDU 1325 Is It A Tree?

HDU 1325 Is It A Tree?

A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties.
There is exactly one node, called the root, to which no directed edges point.

Every node except the root has exactly one edge pointing to it.

There is a unique sequence of directed edges from the root to each node.

For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.



In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

InputThe input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.
OutputFor each test case display the line ``Case k is a tree." or the line ``Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).
Sample Input
6 8 5 3 5 2 6 4
5 6 0 0
8 1 7 3 6 2 8 9 7 5
7 4 7 8 7 6 0 0
3 8 6 8 6 4
5 3 5 6 5 2 0 0
-1 -1
Sample Output
Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.
奇怪的題目,正常輸入輸出,然後統計入度出度,然後出度過多或者入度過多就不是樹

#define _CRT_SECURE_NO_WARNINGS
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<string>
#include<vector>
#include<stack>
#include<cstdlib>
#include<cmath>
#include<queue>
using namespace std;
typedef long long ll;
#define Inf 99999999
#define Maxn 100005
#define Naxn 85
using namespace std;
int book[Maxn];
int in[Maxn], out[Maxn];
int k, ccount, sum;

int main()
{
    int a, b, c, d, i;
    while (scanf("%d%d", &a, &b) != EOF)
    {
        sum++;
        if (!a && !b) {
            printf("Case %d is a tree.\n", sum);
            continue;
        }
        if (!a || !b)
        {
            printf("Case %d is not a tree.\n", sum);
            continue;
        }
        if (a < 0 && b < 0) break;
        for (int i = 1; i <= Maxn; i++)
        {
            book[i] = 0;
        }
        memset(in, 0, sizeof(in));
        memset(out, 0, sizeof(out));
        memset(book, 0, sizeof(book));
        k = 0;
        ccount = 0; 
        in[b]++;
        out[a]++;
        book[a] = book[b] = 1;
        while (scanf("%d%d", &c, &d))
        {
            if (!c || !d) break;
            in[d]++;
            out[c]++;
            book[c] = book[d] = 1;
        }



        for (i = 1; i <= Maxn; i++)
        {
            if (book[i] && in[i] == 0) ccount++;
            if (book[i] && in[i] != 1) k++;
        }
        if (ccount > 1 || ccount == 0) {
            printf("Case %d is not a tree.\n", sum);
            continue;
        }
        if (k > 1 || k == 0)
        {
            printf("Case %d is not a tree.\n", sum);
            continue;
        }
        printf("Case %d is a tree.\n", sum);
    }
    return 0;
}