1. 程式人生 > 實用技巧 >D - Wireless Network(無線網路)

D - Wireless Network(無線網路)

題意:給你 N 臺壞了的電腦的座標 ,和一個距離範圍 d .

(在距離範圍內的電腦可以相互通訊,每臺電腦也可以連線兩臺不同的電腦,使他們之間能夠通訊)

輸入任意次數操作:

O x 表示修理好編號為 x 臺的電腦

S x y 判斷電腦 x 和 y 是否能夠通訊 。能則SUCCESS ,不能則FAIL

An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B.

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations.

Input

The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats:
1. "O p" (1 <= p <= N), which means repairing computer p.
2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate.

The input will not exceed 300000 lines.

Output

For each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not.

Sample Input

4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4

Sample Output

FAIL
SUCCESS
#include<cstdio>
#include <stdlib.h>
#include<cmath>
#include <iostream>
#include<cstring> 
#include <algorithm>
using namespace std;
const double esp = 1e-7;
const int maxn = 1000+10;
int p[maxn]; //父節點
int used[maxn]; //標記改點是否修理
int map[maxn][maxn]; //標記連通性
struct Point
{
    double x, y;
}point[maxn];
double dist(Point a, Point b)//在距離範圍內的電腦可以相互通訊
{
    return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}
int find(int x)
{
    return x==p[x]?p[x]:find(p[x]);
}
int merge(int x,int y)
{
    int tx=find(x);
    int ty=find(y);
    if(tx!=ty) p[tx]=ty;
}
int main()
{
    int n,d;
    while(cin>>n>>d)//n臺電腦,距離最長位d; 
    {
        memset(used,0,sizeof(used));
        memset(map,0,sizeof(map));
        for(int i=1;i<=n;i++)
        {
            cin>>point[i].x>>point[i].y;//座標 
        }
        for(int i=1;i<=n;i++)
        {
            p[i]=i;//每一個父節點 
            map[i][i]=1;//從i到i; 
            for(int j=i+1;j<=n;j++)//從i到j 
                if(dist(point[i],point[j])-d<esp)    
                    map[i][j]=map[j][i]=1;
        }
        int x,y;
        getchar();
        char c;
        while(~scanf("%c",&c))
        {
            if(c=='O') 
            {
                scanf("%d",&x);
                if(!used[x])
                {    
                    used[x]=1;
                    for(int i=1;i<=n;i++)//依次判斷 
                        if(used[i]&&map[i][x])
                            merge(x,i);
                }
            }
            else if(c == 'S')
            {
                scanf("%d%d", &x, &y);
                if(find(x) == find(y))
                printf("SUCCESS\n"); //連通
                else printf("FAIL\n"); //不連通
            }
        }
    }
}