1. 程式人生 > >The Cow Lexicon DP

The Cow Lexicon DP

eterm while cows put part sam noise contain bsp

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 10659 Accepted: 5116

Description

Few know that the cows have their own dictionary with W (1 ≤ W ≤ 600) words, each containing no more 25 of the characters ‘a‘..‘z‘. Their cowmunication system, based on mooing, is not very accurate; sometimes they hear words that do not make any sense. For instance, Bessie once received a message that said "browndcodw". As it turns out, the intended message was "browncow" and the two letter "d"s were noise from other parts of the barnyard.

The cows want you to help them decipher a received message (also containing only characters in the range ‘a‘..‘z‘) of length L (2 ≤ L ≤ 300) characters that is a bit garbled. In particular, they know that the message has some extra letters, and they want you to determine the smallest number of letters that must be removed to make the message a sequence of words from the dictionary.

Input

Line 1: Two space-separated integers, respectively: W and L
Line 2: L characters (followed by a newline, of course): the received message
Lines 3..W+2: The cows‘ dictionary, one word per line

Output

Line 1: a single integer that is the smallest number of characters that need to be removed to make the message a sequence of dictionary words.

Sample Input

6 10
browndcodw
cow
milk
white
black
brown
farmer

Sample Output

2

Source

dp[i]表示位置i之前匹配的最小距離,從前到後刷新最優解。
對於每個位置i,在字典中求他的匹配,在字符串中匹配到最長位置p,然後dp[p] = min(dp[p],dp[i]+ p - len-i)
#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<sstream>
#include<algorithm>
#include<queue>
#include<deque>
#include<iomanip>
#include<vector>
#include<cmath>
#include<map>
#include<stack>
#include<set>
#include<fstream>
#include<memory>
#include<list>
#include<string>
using namespace std;
typedef long long LL;
typedef unsigned long long ULL;
#define MAXN 606
#define MOD 1000000
#define INF 1000000009
#define eps 0.00000001
using namespace std;
/*

*/
char dict[MAXN][26];
char str[302];
int len[MAXN], dp[MAXN], w, l;
int main()
{
    scanf("%d%d", &w, &l);
    scanf("%s", str);
    for (int i = 0; i < w; i++)
    {
        scanf("%s", dict[i]);
        len[i] = strlen(dict[i]);
    }
    for (int i = 0; i <= l; i++)
        dp[i] = INF;
    dp[0] = 0;
    for (int i = 0; i < l;i++)
    {
        dp[i + 1] = min(dp[i + 1], dp[i] + 1);
        for (int j = 0; j < w; j++)
        {
            if (dict[j][0] == str[i])
            {
                int pos = i, k = 0;
                while (pos < l)
                {
                    if (str[pos++] == dict[j][k])
                        k++;
                    if (k == len[j])
                    {
                        dp[pos] = min(dp[pos], dp[i] + pos - i - len[j]);
                        break;
                    }
                }
            }
        }
    }
    printf("%d\n", dp[l]);
    return 0;
}

這道題和昨天CF的C題有點像哦。

The Cow Lexicon DP