1. 程式人生 > >Relative atomic mass

Relative atomic mass

for input itl 分享 letter average first ould arc

Relative atomic mass

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 617 Accepted Submission(s): 516


Problem Description Relative atomic mass is a dimensionless physical quantity, the ratio of the average mass of atoms of an element (from a single given sample or source) to 1技術分享2技術分享技術分享技術分享
of the mass of an atom of carbon-12 (known as the unified atomic mass unit).
You need to calculate the relative atomic mass of a molecule, which consists of one or several atoms. In this problem, you only need to process molecules which contain hydrogen atoms, oxygen atoms, and carbon atoms. These three types of atom are written as ’H’,’O’ and ’C’ repectively. For your information, the relative atomic mass of one hydrogen atom is 1, and the relative atomic mass of one oxygen atom is 16 and the relative atomic mass of one carbon atom is 12. A molecule is demonstrated as a string, of which each letter is for an atom. For example, a molecule ’HOH’ contains two hydrogen atoms and one oxygen atom, therefore its relative atomic mass is 18 = 2 * 1 + 16.

Input The first line of input contains one integer N(N ≤ 10), the number of molecules. In the next N lines, the i-th line contains a string, describing the i-th molecule. The length of each string would not exceed 10.

Output For each molecule, output its relative atomic mass.

Sample Input 5 H C O HOH CHHHCHHOH

Sample Output 1 12 16 18 46 Source 2016ACM/ICPC亞洲區沈陽站-重現賽(感謝東北大學) 【思路】模擬 【code】
#include<iostream>
#include<cstdio>
using namespace std;
string s;
int ans,n;
int main()
{
    scanf("%d",&n);
    for(int i=1;i<=n;i++)
    {
        cin>>s;ans=0;
        for(int i=0;i<s.size();i++)
        {
            if(s[i]==C)ans+=12;
            if(s[i]==O)ans+=16;
            if(s[i]==H)ans++;
        }
        printf("%d\n",ans);
     } 
    return 0;
}

Relative atomic mass