1. 程式人生 > >POJ 3107 Godfather

POJ 3107 Godfather

cat nbsp god dfs edge any color ins incr

Godfather

時限:2000ms

Description

Last years Chicago was full of gangster fights and strange murders. The chief of the police got really tired of all these crimes, and decided to arrest the mafia leaders.

Unfortunately, the structure of Chicago mafia is rather complicated. There are n persons known to be related to mafia. The police have traced their activity for some time, and know that some of them are communicating with each other. Based on the data collected, the chief of the police suggests that the mafia hierarchy can be represented as a tree. The head of the mafia, Godfather, is the root of the tree, and if some person is represented by a node in the tree, its direct subordinates are represented by the children of that node. For the purpose of conspiracy the gangsters only communicate with their direct subordinates and their direct master.

Unfortunately, though the police know gangsters’ communications, they do not know who is a master in any pair of communicating persons. Thus they only have an undirected tree of communications, and do not know who Godfather is.

Based on the idea that Godfather wants to have the most possible control over mafia, the chief of the police has made a suggestion that Godfather is such a person that after deleting it from the communications tree the size of the largest remaining connected component is as small as possible. Help the police to find all potential Godfathers and they will arrest them.

Input

The first line of the input file contains n — the number of persons suspected to belong to mafia (2 ≤ n ≤ 50 000). Let them be numbered from 1 to n.

The following n ? 1 lines contain two integer numbers each. The pair ai, bi means that the gangster ai has communicated with the gangster bi. It is guaranteed that the gangsters’ communications form a tree.

Output

Print the numbers of all persons that are suspected to be Godfather. The numbers must be printed in the increasing order, separated by spaces.

Sample Input

6
1 2
2 3
2 5
3 4
3 6

Sample Output

2 3
這道和博客的上一個POJ1655一樣,求出樹的重心,只是上一個統計節點的編號最小的重心,這個是升序輸出所有節點的重心,水一片博客。
#include "stdio.h"
#include "algorithm"
#include "string.h"
using namespace std;
const int INF = 0x3f3f3f3f;
const int maxn = 50000 + 10;
bool vis[maxn];
struct edge {
    int to, next;
} e[maxn*2];
int n, num[maxn];
int size;
int tot = 0, cnt;
int cur[maxn];
int head[maxn];
void add_edge(int u, int v) {
    e[tot].to = v; e[tot].next = head[u];
    head[u] = tot++;
}
void dfs(int u) {
    num[u] = 0;
    int tr = 0;
    vis[u] = true;
    for (int i = head[u]; i != -1; i = e[i].next) {
        int v = e[i].to;
        if (vis[v]) continue;
        dfs(v);
        num[u] += num[v] + 1;
        tr = max(num[v] + 1, tr);
    } 
    tr = max(n - num[u] - 1, tr); //剩下那棵樹的大小
    if (tr < size) { 
        size = tr;
        cnt = 0;
        cur[cnt++] = u;
    }
    else if (tr == size) {
        cur[cnt++] = u;
    }
}
void init() {
    memset(vis, false, sizeof(vis));
    memset(head, -1, sizeof(head));
    tot = 0; size = INF; cnt = 0;
}
int main(int argc, char const *argv[])
{
    while (scanf("%d", &n)!=EOF) {
        init();
        
        for (int i = 0; i < n-1; i++) {
            int u, v;
            scanf("%d%d", &u, &v); add_edge(u, v);
            add_edge(v, u);
        }
        dfs(1); sort(cur, cur + cnt);
        printf("%d", cur[0]);
        for (int i = 1; i < cnt; i++) printf(" %d", cur[i]);
            printf("\n");
    }
    return 0;
}

 

POJ 3107 Godfather