1. 程式人生 > >HDU-1698 Just a Hook (線段樹、段變換(覆蓋))

HDU-1698 Just a Hook (線段樹、段變換(覆蓋))

++ first rom c11 scan limit field sticks example

Just a Hook

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 34542 Accepted Submission(s): 16868


Problem Description In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.

技術分享


Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.

Input The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.

Output For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.

Sample Input 1 10 2 1 5 2 5 9 3

Sample Output Case 1: The total value of the hook is 24.

Source 2008 “Sunline Cup” National Invitational Contest

Recommend wangye

題目大意:對於每組數據,給定鉤子段數n,默認每段長度開始為1,接著q次變換,每次變換將x~y的鉤子長度變為z。求最後鉤子總長度。

解題思路:就是線段樹,區間的變換變成了區間的覆蓋,最後輸出總長度也就是sum[1]即可。理解後也就是模板題

#include<cstdio>
#include<algorithm>
using namespace std;
const int N=100005;
const int maxn=4*N;
int sum[maxn],lazy[maxn];
int n,x,y,z;

void pushup(int num)
{
    sum[num] = sum[num*2]+sum[num*2+1];
}

void pushdown(int num,int l)
{
    if(lazy[num])
    {
        //lazy、sum對應的值均是直接覆蓋
        lazy[num*2] = lazy[num];
        lazy[num*2+1] = lazy[num];

        sum[num*2] = lazy[num]*(l-l/2);
        sum[num*2+1] = lazy[num]*(l/2);

        lazy[num] = 0;
    }
}

void build(int num,int l,int r)
{
    lazy[num] = 0;
    sum[num] = 1;//默認每段為1
    if(l==r)
    {
        return ;
    }
    int mid=(l+r)/2;
    build(num*2,l,mid);
    build(num*2+1,mid+1,r);
    pushup(num);
}

void update(int num,int l,int r)
{
    if(x<=l&&y>=r)
    {
        //lazy、sum對應的值均是直接覆蓋
        lazy[num] = z;
        sum[num] = z*(r-l+1);
        return ;
    }
    pushdown(num,r-l+1);
    int mid=(l+r)/2;
    if(x<=mid)
        update(num*2,l,mid);
    if(y>mid)
        update(num*2+1,mid+1,r);
    pushup(num);
}

int query(int num,int l,int r)
{
    if(x<=l&&y>=r)
    {
        return sum[num];
    }
    pushdown(num,r-l+1);
    int mid=(l+r)/2,ans=0;
    if(mid>=x)
        ans += query(num*2,l,mid);
    if(mid<y)
        ans += query(num*2,mid+1,r);
    return ans;
}

int main()
{
    int T;
    int Case=1;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        int m;
        build(1,1,n);
        scanf("%d",&m);
        for(int i=1;i<=m;i++)
        {
            scanf("%d %d %d",&x,&y,&z);
            update(1,1,n);
        }
        //x=1;y=n;
        //int ans = query(1,1,n);
        printf("Case %d: The total value of the hook is %d.\n",Case++,sum[1]);
    }
}

HDU-1698 Just a Hook (線段樹、段變換(覆蓋))