1. 程式人生 > >Stars POJ - 2352

Stars POJ - 2352

end amp wid https ont http img logs ostream

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.
技術分享

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it‘s formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

1
2
1
1
0

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.
#include<iostream>
#include<algorithm>
#include<cstdio>
#include<vector>
#include<string>
#include<cstring>
using namespace std;
typedef long long LL;
const int MAXN = 32003;
/*
前面的必定比當前的低
只需要考慮在當前的左邊的
*/
int a[MAXN];
int lowbit(int x)
{
    return x&(-x);
}
void update(int x, int val)
{
    while (x < MAXN)
    {
        a[x] += val;
        x += lowbit(x);
    }
}
int query(int x)
{
    int sum = 0;
    while (x > 0)
    {
        sum += a[x];
        x -= lowbit(x);
    }
    return sum;
}
int n;
int level[MAXN];
int main()
{
    scanf("%d", &n);
        memset(a, 0, sizeof(a));
        memset(level, 0, sizeof(level));
        int x, y;
        for (int i = 1; i <= n; i++)
        {
            scanf("%d%d", &x, &y);
            x++;
            level[query(x)]++;
            update(x, 1);
        }
        for (int i = 0; i < n; i++)
            printf("%d\n", level[i]);
    
}

Stars POJ - 2352