1. 程式人生 > >Pat:1006

Pat:1006

clas esp more con number cto ras positive ecif

1006. Sign In and Sign Out (25)

時間限制 400 ms 內存限制 65536 kB 代碼長度限制 16000 B 判題程序 Standard 作者 CHEN, Yue

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in‘s and out‘s, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time

where times are given in the format HH:MM:SS, and ID number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:
3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40
Sample Output:
SC3021234 CS301133

思路
很簡單,找到最小登入時間的id和最大登出時間的id輸出即可。時間直接轉換成int型比較大小。

代碼
#include<iostream>
#include<vector>
using namespace std;
int main()
{
    int N;
    while(cin >> N)
    {
        vector<string> id(N);
        string signin,signout;
        int minsignin = 2400001,maxsignout = -1;
        int minIndex = 0,maxIndex = 0;
        for(int i = 0; i < N;i++)
        {
            cin>>id[i] >> signin >> signout;
            int intime = stoi(signin.erase(2,1).erase(4,1));
            int outtime = stoi(signout.erase(2,1).erase(4,1));
            if(intime < minsignin)
            {
                minIndex = i;
                minsignin = intime;
            }

            if(outtime > maxsignout)
            {
                maxIndex = i;
                maxsignout = outtime;
            }
        }
        cout << id[minIndex] << " " << id[maxIndex] << endl;
    }
}

Pat:1006