1. 程式人生 > >PAT1125:Chain the Ropes

PAT1125:Chain the Ropes

stream 升序 name make spa main for 對比 eat

1125. Chain the Ropes (25)

時間限制 200 ms 內存限制 65536 kB 代碼長度限制 16000 B 判題程序 Standard 作者 CHEN, Yue

Given some segments of rope, you are supposed to chain them into one rope. Each time you may only fold two segments into loops and chain them into one piece, as shown by the figure. The resulting chain will be treated as another segment of rope and can be folded again. After each chaining, the lengths of the original two segments will be halved.

技術分享

Your job is to make the longest possible rope out of N given segments.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (2 <= N <= 104). Then N positive integer lengths of the segments are given in the next line, separated by spaces. All the integers are no more than 104

.

Output Specification:

For each case, print in a line the length of the longest possible rope that can be made by the given segments. The result must be rounded to the nearest integer that is no greater than the maximum length.

Sample Input:
8
10 15 12 3 4 13 1 15
Sample Output:
14

思路

可以用哈夫曼樹的思路(其實本質就是一個貪婪算法):優先選兩個最小的繩子合成新的繩子,然後循環即可。
所以為了得到最長的繩子,那麽只需要對輸入數據升序排下序即可。

代碼
#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;
int main()
{
  int N;
  while(cin >> N)
  {
   vector<int> ropes(N);
   for(int i = 0;i < N;i++)
   {
      cin >> ropes[i];
   }
   sort(ropes.begin(),ropes.end());
   int length = 0;
   for(int i = 0;i < N ;i++)
   {
      if(i == 0)
      {
        length = ropes[i];
        continue;
      }
      length = (length + ropes[i])/2;
   }
   cout << length << endl;
  }
}

PAT1125:Chain the Ropes