trunk vlan 加路由
1.
不同交換機 vlan間的trunk鏈路連接
拓撲圖:圖1
交換機SW1:
enable
configure terminal
hostname SW1
no ip domain lookup
line console 0
exec-timeout 0 0 #實際項目中不做該命令
line vty 0 4
no login /or/ password 666
exit
enable secret 888
vlan 2
name whatyouwant1
vlan 3
name whatyouwant2
exit
interface fastethernet 0/1
no shutdown #這條命令雖然多余 但 是條件反射666老鐵沒毛病...
switchport mode access #修改接口模式 雖然大部份默認access可不配,但設備如果是trunk模式下面命令不報錯 但配置將無效 保險起見配置以下
switchport access vlan 2
description PC-1
interface fastethernet 0/2
no shutdown #多余 多敲不吃虧
switchport mode access
switchport access vlan 3
description PC-2
interface fastethernet 0/3
no shutdown
switchport mode trunk
description Trunk to SW2 fast0/3
end
show vlan brief
show interfaces trunk
write #互通ping測試 無誤後
交換機SW2:
步驟同SW1 參數描述不同 如圖2
2.
在 1 基礎上,使得不同vlan可以互通。
方案1.
拓撲圖:圖2(實現做法之一)
在1基礎上,添加一臺路由器
交換機SW1:
enable
configure terminal
interface fastethernet 0/4
no shutdown
switchport mode access
switchport access vlan 2
end
show vlan brief
show interface fastethernet 0/4 switchport
write
交換機SW2:
步驟同SW1
fast0/4 加入vlan 3
方案2.
拓撲圖:圖3(實現做法之一)
在1基礎上,添加一臺三層交換機
交換機SW1:
enable
configure terminal
interface fastethernet 0/4
no shutdown
switchport mode trunk
end
show interface fastethernet 0/4 switchport
show vlan brief
write
三層交換機R1:
enable
configure terminal
hostname R1
no ip domain lookup
enable secret 666
line console 0
exec-timeout 0 0
line vty 0 4
no login //password 888
exit
ip routing
vlan 2
name hahaha
vlan 3
name wawawa
interface vlan 2
ip address 192.168.1.3 255.255.255.0
interface vlan 3
ip address 192.168.2.3 255.255.255.0
interface fastethernet 0/1
no shutdown
switchport trunk encapsulation dot1q #指定封裝協議 根據設備而定
switchport mode trunk
end
show ip interface brief
show vlan brif
show interface fastethernet 0/1 switchport
write #ping測試互通後
今天就寫這麽多了。
trunk vlan 加路由