1. 程式人生 > >hrbust 訓練賽 - - - hdu 1016

hrbust 訓練賽 - - - hdu 1016

using separate i++ rate cloc rip 開始 compose span

1、鏈接:

http://acm.hrbust.edu.cn/vj/index.php?c=problem-problem&id=2178

題目:

Description

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.

Input

n (0 < n < 20).
Output

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
Sample Input

6
8
Sample Output

Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2
Source

Asia 1996, Shanghai (Mainland China)

2、解題分析:

題意:給定數n,要求1~n的n個數 從1開始 組成一個環,沒相鄰的兩個數的和為質數(素數)。ps:首尾相接處也要判斷

解法:利用dfs實現全排列,從全排列中篩選符合條件的,但是要一邊DFS一邊判斷目前狀態是否合法,可以實現優化。

3、代碼

#include<bits/stdc++.h>
using namespace std;

int n;
int step;
int vis[105];
int ans[105];

int prime[12] = {2,3,5,7,11,13,17,19,23,29,31,37};//打表

bool primer_num(int x) //素數判斷
{
    for(int i = 0; i < 12; i++)
        if(x == prime[i])
            return true;
    return false;
}

void dfs(int step)
{
    if(step == n + 1)
    {
        if(primer_num(ans[n] + ans[1])){
            for(int i = 1; i <= n; i++)
            {
                printf("%d",ans[i]);
                if(i != n)
                    printf(" ");
                else
                {
                    printf("\n");
                }
            }
        }
    }

    for(int i = 2 ; i <= n; i++)
    {
        if(vis[i] == 0 && primer_num(ans[step-1] + i))
        {
            vis[i] = 1;
            ans[step] = i;
            dfs(step + 1);
            vis[i] = 0;
        }
    }
}
int main()
{
    int cas = 1;
    while(~scanf("%d",&n))
    {
        memset(vis, 0 ,sizeof(vis));
        printf("Case %d:\n",cas++);
        ans[1] = 1;
        dfs(2);
        puts("");
    }
    return 0;
}

hrbust 訓練賽 - - - hdu 1016