1. 程式人生 > >bzoj2527 [Poi2011]Meteors

bzoj2527 [Poi2011]Meteors

前綴和 turn 發現 name 否則 task pre stream scrip

2527: [Poi2011]Meteors

Time Limit: 60 Sec Memory Limit: 128 MB
Submit: 2097 Solved: 764
[Submit][Status][Discuss]

Description

Byteotian Interstellar Union (BIU) has recently discovered a new planet in a nearby galaxy. The planet is unsuitable for colonisation due to strange meteor showers, which on the other hand make it an exceptionally interesting object of study. The member states of BIU have already placed space stations close to the planet‘s orbit. The stations‘ goal is to take samples of the rocks flying by. The BIU Commission has partitioned the orbit into msectors, numbered from 1to m, where the sectors 1and mare adjacent. In each sector there is a single space station, belonging to one of the nmember states. Each state has declared a number of meteor samples it intends to gather before the mission ends. Your task is to determine, for each state, when it can stop taking samples, based on the meter shower predictions for the years to come. Byteotian Interstellar Union有N個成員國。現在它發現了一顆新的星球,這顆星球的軌道被分為M份(第M份和第1份相鄰),第i份上有第Ai個國家的太空站。
這個星球經常會下隕石雨。BIU已經預測了接下來K場隕石雨的情況。
BIU的第i個成員國希望能夠收集Pi單位的隕石樣本。你的任務是判斷對於每個國家,它需要在第幾次隕石雨之後,才能收集足夠的隕石。
輸入:
第一行是兩個數N,M。
第二行有M個數,第i個數Oi表示第i段軌道上有第Oi個國家的太空站。
第三行有N個數,第i個數Pi表示第i個國家希望收集的隕石數量。
第四行有一個數K,表示BIU預測了接下來的K場隕石雨。
接下來K行,每行有三個數Li,Ri,Ai,表示第K場隕石雨的發生地點在從Li順時針到Ri的區間中(如果Li<=Ri,就是Li,Li+1,...,Ri,否則就是Ri,Ri+1,...,m-1,m,1,...,Li),向區間中的每個太空站提供Ai單位的隕石樣本。
輸出:
N行。第i行的數Wi表示第i個國家在第Wi波隕石雨之後能夠收集到足夠的隕石樣本。如果到第K波結束後仍然收集不到,輸出NIE。
數據範圍:
數據範圍: 1<=n,m,k<=3*10^5 1<=Pi<=10^9 1<=Ai<10^9

Input

The first line of the standard input gives two integers, n and m(1<=n,m<=3*10^5) separated by a single space, that denote, respectively, the number of BIU member states and the number of sectors the orbit has been partitioned into. In the second line there are mintegers Oi(1<=Oi<=n) separated by single spaces, that denote the states owning stations in successive sectors. In the third line there are nintegers Pi(1<=Pi<=10^9) separated by single spaces, that denote the numbers of meteor samples that the successive states intend to gather. In the fourth line there is a single integer k(1<=k<=3*10^5) that denotes the number of meteor showers predictions. The following klines specify the (predicted) meteor showers chronologically. The i-th of these lines holds three integers Li, Ri, Ai(separated by single spaces), which denote that a meteor shower is expected in sectors Li,Li+1,…Ri (if Li<=Ri) or sectors Li,Li+1,…,m,1,…Ri (if Li>Ri), which should provide each station in those sectors with Aimeteor samples (1<=Ai<10^9). In tests worth at least 20% of the points it additionally holds that .

Output

Your program should print nlines on the standard output. The i-th of them should contain a single integer Wi, denoting the number of shower after which the stations belonging to the i-th state are expected to gather at least Pi samples, or the word NIE (Polish for no) if that state is not expected to gather enough samples in the foreseeable future.

Sample Input

3 5
1 3 2 1 3
10 5 7
3
4 2 4
1 3 1
3 5 2

Sample Output

3
NIE
1

Source

鳴謝 Object022

分析:如果只詢問一個點要怎麽做呢? 當然是二分咯,記錄一下每次隕石雨的前綴和就行了.

   多個點詢問怎麽辦?整體二分!

   一個國家可能在多個軌道都有太空站,用鏈表存一下.

   怎麽判斷不合法的情況呢? 增加一場隕石雨,數量為inf. 這就保證了如果之前的隕石雨都不能滿足,最後一場一定會滿足,看看最後是否有點的答案為k + 1即可.

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>

using namespace std;

typedef long long ll;
const ll maxn = 300010,inf = 0x7fffffff;
ll n,m,a[maxn],head[maxn],nextt[maxn],to[maxn],k,tot = 1,goal[maxn],ans[maxn],c[maxn],t1[maxn],t2[maxn];

struct node
{
    ll l,r,v;
} e[maxn];

void add(ll x,ll y)
{
    to[tot] = y;
    nextt[tot] = head[x];
    head[x] = tot++;
}

void update(ll x,ll v)
{
    while(x <= m)
    {
        c[x] += v;
        x += x & (-x);
    }
}

ll query(ll x)
{
    ll res = 0;
    while (x)
    {
        res += c[x];
        x -= x & (-x);
    }
    return res;
}

void modify(ll l,ll r,ll v)
{
    update(l,v);
    update(r + 1,-v);
}

void solve(ll L,ll R,ll l,ll r)
{
    if (L > R)
        return;
    if (l == r)
    {
        for (ll i = L; i <= R; i++)
            ans[a[i]] = l;
        return;
    }
    ll mid = (l + r) >> 1;
    for (ll i = l; i <= mid; i++)
    {
        if (e[i].l <= e[i].r)
            modify(e[i].l,e[i].r,e[i].v);
        else
        {
            modify(1,e[i].r,e[i].v);
            modify(e[i].l,m,e[i].v);
        }
    }
    ll p1 = 0,p2 = 0;
    for (ll i = L; i <= R; i++)
    {
        ll temp = a[i],res = 0;
        for (ll j = head[temp]; j; j = nextt[j])
        {
            ll v = to[j];
            res += query(v);
            if (res >= goal[temp])
                break;
        }
        if (res >= goal[temp])
            t1[++p1] = temp;
        else
        {
            goal[temp] -= res;
            t2[++p2] = temp;
        }
    }
    for (ll i = l; i <= mid; i++)
    {
        if (e[i].l <= e[i].r)
            modify(e[i].l,e[i].r,-e[i].v);
        else
        {
            modify(1,e[i].r,-e[i].v);
            modify(e[i].l,m,-e[i].v);
        }
    }
    for (ll i = 1; i <= p1; i++)
        a[i + L - 1] = t1[i];
    for (ll i = 1; i <= p2; i++)
        a[i + L + p1 - 1] = t2[i];
    solve(L,L + p1 - 1,l,mid);
    solve(L + p1,R,mid + 1,r);
}

int main()
{
    scanf("%lld%lld",&n,&m);
    for (ll i = 1; i <= m; i++)
    {
        ll x;
        scanf("%lld",&x);
        add(x,i);
    }
    for (ll i = 1; i <= n; i++)
    {
        scanf("%lld",&goal[i]);
        a[i] = i;
    }
    scanf("%lld",&k);
    for (ll i = 1; i <= k; i++)
        scanf("%lld%lld%lld",&e[i].l,&e[i].r,&e[i].v);
    e[++k].l = 1;
    e[k].r = m;
    e[k].v = inf;
    solve(1,n,1,k);
    for (ll i = 1; i <= n; i++)
    {
        if (ans[i] != k)
            printf("%lld\n",ans[i]);
        else
            printf("NIE\n");
    }

    return 0;
}

bzoj2527 [Poi2011]Meteors