跳一跳遊戲。《動態規劃》
動態規劃的題型中要抽象出遞歸相類似的表達式。動態規劃,給我的感覺就是一個存表和查表操作,而且這兩個操作在物理和邏輯上是連續的。
Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.
The game can be played by two or more than two players. It consists of a chessboard(棋盤)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.
Your task is to output the maximum value according to the given chessmen list.
InputInput contains multiple test cases. Each test case is described in a line as follow:
N value_1 value_2 …value_N
It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.
A test case starting with 0 terminates the input and this test case is not to be processed.
OutputFor each case, print the maximum according to rules, and one line one case.
Sample Input
3 1 3 2 4 1 2 3 4 4 3 3 2 1 0
Sample Output
4 10 3
代碼如下:
#include<iostream>
using namespace std;
#define Max 1000
int max(int a, int b)
{
return a > b ? a : b;
}
int main()
{
int num[Max];
int dp[Max];
int datanum;
while (~scanf("%d",&datanum) && datanum)
{
//輸入數據
for (int i = 1; i <= datanum; i++)
{
cin >> num[i];
dp[i] = 0;
}
dp[0] = 0;
int ans = 0;
for (int i = 1; i <= datanum; i++)
{
dp[i] = num[i];
for (int j = 1; j <= i; j++)
{
if (num[j] < num[i])
{
dp[i] = max(dp[i], dp[j] + num[i]);
}
}
ans = max(ans, dp[i]);
}
cout << ans <<endl;
}
return 0;
}
——————————————————————結束————————————————
for (int i = 1; i <= datanum; i++)
{
dp[i] = num[i];
for (int j = 1; j <= i; j++)
{
if (num[j] < num[i])
{
dp[i] = max(dp[i], dp[j] + num[i]);
}
}
ans = max(ans, dp[i]);
}
這是最重要的一段,
每輸入一個值存入到dp中,然後遍歷num中i後面的數字,只要比他小,就進入if中然後將dp[i]於從前的dp[i]加上當前的num的和作比較。在賦給dp[i]這是一個制表的過程。註意:當出現遞減的情況,它不會進入if中,也就是說,再次遇到遞增時,它是在一次從該段遞增的序列中從新制表和累計的。
跳一跳遊戲。《動態規劃》