CCNA RIP 實驗
配置一下路由器接口
R1#sh ip int b
Interface IP-Address OK? Method Status Protocol
Serial1/0 unassigned YES unset administratively down down
Serial1/1 unassigned YES unset administratively down down
Serial1/2 unassigned YES unset administratively down down
Serial1/3 unassigned YES unset administratively down down
R1#
R1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#int s1/1
R1(config-if)#ip address 12.12.12.1 255.255.255.252
R1(config-if)#no sh
R1(config-if)#
*Mar 1 00:05:29.123: %LINK-3-UPDOWN: Interface Serial1/1, changed state to up
*Mar 1 00:05:30.123: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/1, changed state to up
R1(config-if)#
R1#sh ip int b
Interface IP-Address OK? Method Status Protocol
Serial1/0 unassigned YES unset administratively down down
Serial1/1 12.12.12.1 YES manual up down
Serial1/2 unassigned YES unset administratively down down
Serial1/3 unassigned YES unset administratively down down
R1#
中間路由器
R2#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)#int s1/0
R2(config-if)#ip ad
R2(config-if)#ip address 12.12.12.2 255.255.255.252
R2(config-if)#no sh
R2(config-if)#
*Mar 1 00:07:36.079: %LINK-3-UPDOWN: Interface Serial1/0, changed state to up
*Mar 1 00:07:37.079: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/0, changed state to up
R2(config-if)#do ping 12.12.12.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 12.12.12.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
直連怎麽可能沒通,再來
R2(config-if)#do ping 12.12.12.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 12.12.12.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/24/32 ms
好了
R2#sh ip int br
Interface IP-Address OK? Method Status Protocol
Serial1/0 12.12.12.2 YES manual up up
Serial1/1 unassigned YES unset administratively down down
Serial1/2 unassigned YES unset administratively down down
Serial1/3 unassigned YES unset administratively down down
R2#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)#int s1/1
R2(config-if)#ip add
R2(config-if)#ip address 23.23.23.1 255.255.255.252
R2(config-if)#no sh
R2(config-if)#
*Mar 1 00:10:07.467: %LINK-3-UPDOWN: Interface Serial1/1, changed state to up
*Mar 1 00:10:08.467: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/1, changed state to up
R2(config-if)#
R2#sh ip int b
Interface IP-Address OK? Method Status Protocol
Serial1/0 12.12.12.2 YES manual up up
Serial1/1 23.23.23.1 YES manual up down
Serial1/2 unassigned YES unset administratively down down
Serial1/3 unassigned YES unset administratively down down
R2#
2個ip都好了
最右面的
R3(config)#int s1/0
R3(config-if)#ip address 23.23.23.2 255.255.255.252
R3(config-if)#no sh
R3(config-if)#
*Mar 1 00:12:58.627: %LINK-3-UPDOWN: Interface Serial1/0, changed state to up
*Mar 1 00:12:59.627: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/0, changed state to up
R3(config-if)#
R3#sh ip int b
Interface IP-Address OK? Method Status Protocol
Serial1/0 23.23.23.2 YES manual up up
Serial1/1 unassigned YES unset administratively down down
Serial1/2 unassigned YES unset administratively down down
Serial1/3 unassigned YES unset administratively down down
R3#ping 23.23.23.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 23.23.23.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/21/28 ms
R3#
開始配置rip
R1(config)#router rip
R1(config-router)#version 2
R1(config-router)#no auto-summary
R1(config-router)#network 12.0.0.0
R2(config)#router rip
R2(config-router)#version 2
R2(config-router)#no auto-summary
R2(config-router)#network 12.0.0.0
R2(config-router)#network 23.0.0.0
R3(config)#router rip
R3(config-router)#version 2
R3(config-router)#no auto-summary
R3(config-router)#network 23.0.0.0
R1已經有路由表了
R1#sh ip ro
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
23.0.0.0/30 is subnetted, 1 subnets
R 23.23.23.0 [120/1] via 12.12.12.2, 00:00:14, Serial1/1
12.0.0.0/30 is subnetted, 1 subnets
C 12.12.12.0 is directly connected, Serial1/1
R1#ping 23.23.23.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 23.23.23.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/54/76 ms
開一下debug看事件
R1#debug ip rip data
R1#debug ip rip database
RIP database events debugging is on
R1#debug ip rip events
RIP event debugging is on
R1#debug ip rip trigger
RIP trigger debugging is on
R1#debug ip rip
其余兩個常用命令
R1#sh ip ro
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
23.0.0.0/30 is subnetted, 1 subnets
R 23.23.23.0 [120/1] via 12.12.12.2, 00:00:02, Serial1/1
12.0.0.0/30 is subnetted, 1 subnets
C 12.12.12.0 is directly connected, Serial1/1
R1#
*Mar 1 00:26:59.175: RIP-TIMER: age timer expired
R1#sh ip pro
R1#sh ip protocols
Routing Protocol is "rip"
Sending updates every 30 seconds, next due in 13 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Redistributing: rip
Default version control: send version 2, receive version 2
Interface Send Recv Triggered RIP Key-chain
Serial1/1 2 2
Automatic network summarization is not in effect
Maximum path: 4
Routing for Networks:
12.0.0.0
Routing Information Sources:
Gateway Distance Last Update
12.12.12.2 120 00:00:12
Distance: (default is 120)
命令1分鐘,截圖5分鐘
CCNA RIP 實驗