1. 程式人生 > >poj 2431 Expedition

poj 2431 Expedition

output inpu from sed spa resp 當前 span cati

Description

A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor drivers, the cows unfortunately managed to run over a rock and puncture the truck‘s fuel tank. The truck now leaks one unit of fuel every unit of distance it travels.

To repair the truck, the cows need to drive to the nearest town (no more than 1,000,000 units distant) down a long, winding road. On this road, between the town and the current location of the truck, there are N (1 <= N <= 10,000) fuel stops where the cows can stop to acquire additional fuel (1..100 units at each stop).

The jungle is a dangerous place for humans and is especially dangerous for cows. Therefore, the cows want to make the minimum possible number of stops for fuel on the way to the town. Fortunately, the capacity of the fuel tank on their truck is so large that there is effectively no limit to the amount of fuel it can hold. The truck is currently L units away from the town and has P units of fuel (1 <= P <= 1,000,000).

Determine the minimum number of stops needed to reach the town, or if the cows cannot reach the town at all.

Input

* Line 1: A single integer, N

* Lines 2..N+1: Each line contains two space-separated integers describing a fuel stop: The first integer is the distance from the town to the stop; the second is the amount of fuel available at that stop.

* Line N+2: Two space-separated integers, L and P

Output

* Line 1: A single integer giving the minimum number of fuel stops necessary to reach the town. If it is not possible to reach the town, output -1.

Sample Input

4
4 4
5 2
11 5
15 10
25 10

Sample Output

2

Hint

INPUT DETAILS:

The truck is 25 units away from the town; the truck has 10 units of fuel. Along the road, there are 4 fuel stops at distances 4, 5, 11, and 15 from the town (so these are initially at distances 21, 20, 14, and 10 from the truck). These fuel stops can supply up to 4, 2, 5, and 10 units of fuel, respectively.

OUTPUT DETAILS:

Drive 10 units, stop to acquire 10 more units of fuel, drive 4 more units, stop to acquire 5 more units of fuel, then drive to the town.

Source

USACO 2005 U S Open Gold 從起點排著經過由近及遠的stop,同時把經過的站的fuel存在優先隊列裏,起初表示在經過的stop都不停下來,當發現fuel不夠時就從優先隊列取較大的fuel值,然後出隊,表示在此fuel值的stop停下來補充能量,當發現隊列空了以後,fuel仍然不夠時就輸出-1,無法到達town,否則輸出n-q.size(),停駐的stop都已經出隊,剩下的是沒有停的。 代碼: 技術分享圖片
#include <iostream>
#include <algorithm>
#include <queue>
#include <cstdio>
using namespace std;
struct stop
{
    int distance,fuel;
}s[10001];
int n,l,p,flag;
bool cmp(stop a,stop b)
{
    return a.distance > b.distance;
}
int main()
{
    priority_queue <int,vector<int>,less<int> > q;
    scanf("%d",&n);
    s[n].distance = s[n].fuel = 0;
    for(int i = 0;i < n;i ++)
    {
        scanf("%d%d",&s[i].distance,&s[i].fuel);
    }
    scanf("%d%d",&l,&p);
    sort(s,s + n,cmp);///按距離從大到小排,因為是距離town 的距離  所以越大的代表與起點越近
    for(int i = 0;i <= n;i ++)///s[n]的distance為0,代表終點 所以結果要 + 1  因為終點也入隊了 ,多減了一下
    {
        while(p < l - s[i].distance && !q.empty())///p存fuel
        {
            p += q.top();
            q.pop();
        }
        if(p < l - s[i].distance){flag = -1;break;}///l存當前與town 的距離
        p -= l - s[i].distance;
        q.push(s[i].fuel);
        l = s[i].distance;
    }
    if(flag != -1)flag = n - q.size() + 1;
    printf("%d",flag);
}
View Code

poj 2431 Expedition