hdu2004 成績轉換【C++】
阿新 • • 發佈:2018-07-09
ace eof 規則 mes color 數組 desc other put
90~100為A;
80~89為B;
70~79為C;
60~69為D;
0~59為E;
Sample Input
56
67
100
123
成績轉換
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 173950 Accepted Submission(s): 76178
90~100為A;
80~89為B;
70~79為C;
60~69為D;
0~59為E;
Input 輸入數據有多組,每組占一行,由一個整數組成。
Output 對於每組輸入數據,輸出一行。如果輸入數據不在0~100範圍內,請輸出一行:“Score is error!”。
Sample Output E D A Score is error!
1 #include<cstdio> 2 using namespace std; 3 int main() 4 { 5 int x; 6 while(scanf("%d",&x)!=EOF) 7 { 8 if(x>=90 && x <=100) 9 { 10 printf("A\n"); 11 }12 else if(x>=80 && x <=89) 13 { 14 printf("B\n"); 15 } 16 else if(x>=70 && x <=79) 17 { 18 printf("C\n"); 19 } 20 else if(x>=60 && x <=69) 21 { 22 printf("D\n");23 } 24 else if(x>=0 && x <=59) 25 { 26 printf("E\n"); 27 } 28 else 29 { 30 printf("Score is error!\n"); 31 } 32 } 33 return 0; 34 }
hdu2004 成績轉換【C++】