HDU1002 A + B Problem II【大數】
A + B Problem IITime Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 438282 Accepted Submission(s): 85280 Problem Description I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
Input The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
Output For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
Sample Input 2 1 2 112233445566778899 998877665544332211
Sample Output Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
Author Ignatius.L
Recommend |
#include <iostream>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
const int BASE = 10;
const int N = 1000;
char sa[N+1],sb[N+1];
int a[N+1],b[N+1];
int main()
{
int t;
scanf("%d",&t);
for(int k=1;k<=t;k++){
scanf("%s%s",sa,sb);
//字串轉數值陣列
memset(a,0,sizeof(a));
memset(b,0,sizeof(b));
int alen = strlen(sa);
for(int i=alen-1,j=0;i>=0;i--,j++){
a[j] = sa[i] - '0';//關鍵程式碼,把字串轉換為數值
}
int blen = strlen(sb);
for(int i=blen-1,j=0;i>=0;i--,j++){
b[j] = sb[i] - '0';//同理
}
//相加(需要考慮進位問題)
//倒著加的,從最低位開始相加,把最低位放在陣列的第一個
int len = max(alen,blen);
int carry = 0; //位
for(int i=0;i<len;i++){
a[i] += b[i] + carry;//加上位
carry = a[i]/BASE;
a[i] %= BASE;
}
if(carry >0){
a[len++] = carry;
}//最高位
if(k != 1)
printf("\n");
printf("Case %d:\n", k);
printf ("%s + %s = ", sa, sb);
for(int i=len-1;i>=0;i--){
printf("%d",a[i]);
}//倒著輸出,就是相當於從最高位開始輸出
printf("\n");
}
return 0;
}