1. 程式人生 > >POJ1087 A Plug for UNIX 最大流

POJ1087 A Plug for UNIX 最大流

A Plug for UNIX

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 19053   Accepted: 6632

Description

You are in charge of setting up the press room for the inaugural meeting of the United Nations Internet eXecutive (UNIX), which has an international mandate to make the free flow of information and ideas on the Internet as cumbersome and bureaucratic as possible. 
Since the room was designed to accommodate reporters and journalists from around the world, it is equipped with electrical receptacles to suit the different shapes of plugs and voltages used by appliances in all of the countries that existed when the room was built. Unfortunately, the room was built many years ago when reporters used very few electric and electronic devices and is equipped with only one receptacle of each type. These days, like everyone else, reporters require many such devices to do their jobs: laptops, cell phones, tape recorders, pagers, coffee pots, microwave ovens, blow dryers, curling 
irons, tooth brushes, etc. Naturally, many of these devices can operate on batteries, but since the meeting is likely to be long and tedious, you want to be able to plug in as many as you can. 
Before the meeting begins, you gather up all the devices that the reporters would like to use, and attempt to set them up. You notice that some of the devices use plugs for which there is no receptacle. You wonder if these devices are from countries that didn't exist when the room was built. For some receptacles, there are several devices that use the corresponding plug. For other receptacles, there are no devices that use the corresponding plug. 
In order to try to solve the problem you visit a nearby parts supply store. The store sells adapters that allow one type of plug to be used in a different type of outlet. Moreover, adapters are allowed to be plugged into other adapters. The store does not have adapters for all possible combinations of plugs and receptacles, but there is essentially an unlimited supply of the ones they do have.

Input

The input will consist of one case. The first line contains a single positive integer n (1 <= n <= 100) indicating the number of receptacles in the room. The next n lines list the receptacle types found in the room. Each receptacle type consists of a string of at most 24 alphanumeric characters. The next line contains a single positive integer m (1 <= m <= 100) indicating the number of devices you would like to plug in. Each of the next m lines lists the name of a device followed by the type of plug it uses (which is identical to the type of receptacle it requires). A device name is a string of at most 24 alphanumeric 
characters. No two devices will have exactly the same name. The plug type is separated from the device name by a space. The next line contains a single positive integer k (1 <= k <= 100) indicating the number of different varieties of adapters that are available. Each of the next k lines describes a variety of adapter, giving the type of receptacle provided by the adapter, followed by a space, followed by the type of plug.

Output

A line containing a single non-negative integer indicating the smallest number of devices that cannot be plugged in.

Sample Input

4 
A 
B 
C 
D 
5 
laptop B 
phone C 
pager B 
clock B 
comb X 
3 
B X 
X A 
X D 

Sample Output

1

題意:有n種插座,m種裝置,每個裝置都只能匹配一種插座,注意可以匹配的不一定是給出的n個。又有k個資訊,每個資訊表示插座s1可以連線s2,表示可以匹配插座s1的裝置可以通過s1匹配s2,每個插座預設連線電源,求最少有幾個裝置斷點。

 

源點連所有裝置流量為1,n個插座連匯點每個裝置向匹配的插座連一條流量為1的邊,可以向連的插座s1連向s2,流量為INF,跑一邊最大流,流量即為最多可以通電的插座個數。

#include<stdio.h>
#include<algorithm>
#include<string.h>
#include<string>
#include<map>
#include<queue>
using namespace std;
const int maxm = 1005;
const int INF = 1e9 + 7;
map<string, int>flag;
struct node
{
	int u, v, flow, next;
}edge[maxm];
int n, m, s, t, cnt;
int head[maxm], dis[maxm], pre[maxm], cur[maxm];
char ch[25], sh[25], name[25], typ[25];
void init()
{
	s = 0, t = maxm - 1;
	memset(head, -1, sizeof(head));
}
void add(int u, int v, int flow) 
{ 
	edge[cnt].u = u, edge[cnt].v = v, edge[cnt].flow = flow;
	edge[cnt].next = head[u], head[u] = cnt++;  
	edge[cnt].u = v, edge[cnt].v = u, edge[cnt].flow = 0;
	edge[cnt].next = head[v], head[v] = cnt++;
}
int bfs()
{
	queue<int>q;
	memset(dis, -1, sizeof(dis));
	dis[s] = 0;
	q.push(s);
	while (!q.empty())
	{
		int u = q.front();q.pop();
		for (int i = head[u];i != -1;i = edge[i].next)
		{
			int v = edge[i].v;
			if (dis[v] == -1 && edge[i].flow)
			{
				dis[v] = dis[u] + 1;
				q.push(v);
			}
		}
	}
	if (dis[t] == -1) return 0;
	return 1;
}
int dfs(int u, int flow)
{
	if (u == t) return flow;
	for (int &i = cur[u];i != -1;i = edge[i].next)
	{
		int v = edge[i].v;
		if (dis[v] == dis[u] + 1 && edge[i].flow)
		{
			int d = dfs(v, min(edge[i].flow, flow));
			if (d > 0)
			{
				edge[i].flow -= d;
				edge[i ^ 1].flow += d;
				return d;
			}
		}
	}
	return 0;
}
int dinic()
{
	int ans = 0, d;
	while (bfs())
	{
		for (int i = 0;i <= t;i++) cur[i] = head[i];
		while (d = dfs(s, INF))
			ans += d;
	}
	return ans;
}
int main()
{
	int i, j, k, sum = 0, x;
	init();
	scanf("%d", &n);
	for (i = 1;i <= n;i++)
	{
		scanf("%s", typ);
		flag[typ] = ++sum;
		add(sum, t, 1);
	}
	scanf("%d", &m);
	for (i = 1;i <= m;i++)
	{
		scanf("%s%s", name, typ);
		flag[name] = ++sum;
		if (!flag[typ]) flag[typ] = ++sum;
		add(s, flag[name], 1);
		add(flag[name], flag[typ], 1);
	}
	scanf("%d", &k);
	for (i = 1;i <= k;i++)
	{
		scanf("%s%s", ch, sh);
		if (!flag[sh]) flag[sh] = ++sum;
		if (!flag[ch]) flag[ch] = ++sum;
		add(flag[ch], flag[sh], INF);
	}
	printf("%d\n", m - dinic());
	return 0;
}