【PAT甲級】1028 List Sorting
Excel can sort records according to any column. Now you are supposed to imitate this function.
Input Specification:
Each input file contains one test case. For each case, the first line contains two integers N (≤105) and C, where N is the number of records and C is the column that you are supposed to sort the records with. Then N lines follow, each contains a record of a student. A student's record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).
Output Specification:
For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID's; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID's in increasing order.
Sample Input 1:
3 1
000007 James 85
000010 Amy 90
000001 Zoe 60
Sample Output 1:
000001 Zoe 60
000007 James 85
000010 Amy 90
Sample Input 2:
4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98
Sample Output 2:
000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60
Sample Input 3:
4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 90
Sample Output 3:
000001 Zoe 60
000007 James 85
000002 James 90
000010 Amy 90
個人理解
這題就是根據三個不同的值對同一個結構體陣列進行從小到大對排序然後輸出即可。
注意一個點就是如果成績或者名字相同要按照id從小到大排序。
程式碼實現
#include <cstdio>
#include <cstring>
#include <string>
#include <set>
#include <map>
#include <vector>
#include <cmath>
#include <algorithm>
#include <iostream>
#define ll long long
#define eps 1e-8
#define INF 0x7FFFFFFF
const int maxn = 100005;
using namespace std;
struct Student{
string id, name;
int score;
};
Student students[maxn];
bool cmp1(Student s1, Student s2) {
return s1.id < s2.id;
}
bool cmp2(Student s1, Student s2) {
if (s1.name == s2.name) return s1.id < s2.id;
return s1.name < s2.name;
}
bool cmp3(Student s1, Student s2) {
if (s1.score == s2.score) return s1.id < s2.id;
return s1.score < s2.score;
}
int main() {
// 輸入
int n, c;
cin >> n >> c;
for (int i = 0; i < n; i ++) {
cin >> students[i].id >> students[i].name >> students[i].score;
}
// 排序
if (c == 1) sort(students, students+n, cmp1);
else if (c == 2) sort(students, students+n, cmp2);
else if (c == 3) sort(students, students+n, cmp3);
// 輸出
for (int i = 0; i < n; i ++) {
cout << students[i].id << " " << students[i].name << " " << students[i].score << endl;
}
return 0;
}
總結
學習不息,繼續加油