poj 2069 Super Star—— 模擬退火板子(較精確)
Description
During a voyage of the starship Hakodate-maru (see Problem 1406), researchers found strange synchronized movements of stars. Having heard these observations, Dr. Extreme proposed a theory of “super stars”. Do not take this term as a description of actors or singers. It is a revolutionary theory in astronomy.
According to this theory, starts we are observing are not independent objects, but only small portions of larger objects called super stars. A super star is filled with invisible (or transparent) material, and only a number of points inside or on its surface shine. These points are observed as stars by us.
In order to verify this theory, Dr. Extreme wants to build motion equations of super stars and to compare the solutions of these equations with observed movements of stars. As the first step, he assumes that a super star is sphere-shaped, and has the smallest possible radius such that the sphere contains all given stars in or on it. This assumption makes it possible to estimate the volume of a super star, and thus its mass (the density of the invisible material is known).
You are asked to help Dr. Extreme by writing a program which, given the locations of a number of stars, finds the smallest sphere containing all of them in or on it. In this computation, you should ignore the sizes of stars. In other words, a star should be regarded as a point. You may assume the universe is a Euclidean space.
Input
The input consists of multiple data sets. Each data set is given in the following format.
n
x1 y1 z1
x2 y2 z2
. . .
xn yn zn
The first line of a data set contains an integer n, which is the number of points. It satisfies the condition 4 <= n <= 30.
The location of n points are given by three-dimensional orthogonal coordinates: (xi, yi, zi) (i = 1, …, n). Three coordinates of a point appear in a line, separated by a space character. Each value is given by a decimal fraction, and is between 0.0 and 100.0 (both ends inclusive). Points are at least 0.01 distant from each other.
The end of the input is indicated by a line containing a zero.
Output
For each data set, the radius of the smallest sphere containing all given points should be printed, each in a separate line. The printed values should have 5 digits after the decimal point. They may not have an error greater than 0.00001.
Sample Input
4
10.00000 10.00000 10.00000
20.00000 10.00000 10.00000
20.00000 20.00000 10.00000
10.00000 20.00000 10.00000
4
10.00000 10.00000 10.00000
10.00000 50.00000 50.00000
50.00000 10.00000 50.00000
50.00000 50.00000 10.00000
0
Sample Output
7.07107
34.64102
Source
Japan 2001
題意:
三維空間中有n個點,讓你求一個點,使得距離這個點最遠的點的距離最小,輸出這個距離
題解:
以前用rand()的那些都不能用了,因為不精確,現在又改了板子,用向量來算,每次都往距離最大的那個點的方向移動
#include<iostream>
#include<stdio.h>
#include<stdlib.h>
#include<math.h>
#include<time.h>
using namespace std;
#define eps 1e-8
#define ll long long
int n;
double X,Y,Z;
struct node
{
double x,y,z,val;
}p[35],peop;
double dist(node a,node b)
{
return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y)+(a.z-b.z)*(a.z-b.z));
}
int main()
{
srand((unsigned(time(NULL))));
while(~scanf("%d",&n))
{
if(n==0)
break;
X=Y=Z=100;
for(int i=1;i<=n;i++)
scanf("%lf%lf%lf",&p[i].x,&p[i].y,&p[i].z);
peop.x=(rand()%1000+1)*1.0/1000.0*X;
peop.y=(rand()%1000+1)*1.0/1000.0*Y;
peop.z=(rand()%1000+1)*1.0/1000.0*Z;
peop.val=get(peop);
double T=X;
node ne;
double ans=1e9;
while(T>eps)
{
double now=0;
int who;
for(int j=1;j<=n;j++)
{
if(now<dist(p[j],peop))
{
now=dist(p[j],peop);
who=j;
}
}
peop.x=peop.x+(p[who].x-peop.x)/now*T;//不斷向更優處移動
peop.y=peop.y+(p[who].y-peop.y)/now*T;
peop.z=peop.z+(p[who].z-peop.z)/now*T;
peop.val=get(ne);
if(now<ans)
ans=now;
T*=0.99;
}
printf("%.7f\n",ans);
}
return 0;
}