1. 程式人生 > >hdu sort排序

hdu sort排序

Problem F

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)

Total Submission(s) : 21   Accepted Submission(s) : 19

Problem Description

FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.

 

 

Input

The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.

 

 

Output

For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

 

 

Sample Input

 

5 3 7 2 4 3 5 2 20 3 25 18 24 15 15 10 -1 -1

 

 

Sample Output

 

13.333 31.500

這道題很簡單,只是英語太長,沒有看,說一下題意。。。。。。。。

第一行代表老鼠有限定的貓糧和有幾種兌換的方式,接著n行就是老鼠用貓糧去換自己的糧食;

那麼要想在有限的貓糧中換更多自己的糧食,就要選出最佳的兌換方式,用sort排序就可以,然後需要減去用過的貓糧,繼續兌換,剩下不足的,按照不足的兌換。。。。。

 

#include<bits/stdc++.h>
using namespace std;
struct node
{
    double a,b,k;
}m[1010];
int cmp(node x,node y)
{
    return x.k>y.k;
}
int main()
{
    int t,n;
    double sum;
    while(~scanf("%d%d",&t,&n))
    {
        if(t==-1&&n==-1) break;
        sum=0;
        for(int i=0;i<n;i++)
        {
            scanf("%lf%lf",&m[i].a,&m[i].b);
            m[i].k=m[i].a/m[i].b;
        }
        sort(m,m+n,cmp);
        for(int i=0;i<n;i++)
        {
            if(t>m[i].b)
            {
                sum=sum+m[i].a;
                t=t-m[i].b;
            }
            else
            {
                sum=sum+t*m[i].k;
                break;
            }
        }
        printf("%.3lf\n",sum);
    }
}