1. 程式人生 > >【HDU - 4185】Oil Skimming (二分圖,建圖,匈牙利演算法)

【HDU - 4185】Oil Skimming (二分圖,建圖,匈牙利演算法)

題幹:

Thanks to a certain "green" resources company, there is a new profitable industry of oil skimming. There are large slicks of crude oil floating in the Gulf of Mexico just waiting to be scooped up by enterprising oil barons. One such oil baron has a special plane that can skim the surface of the water collecting oil on the water's surface. However, each scoop covers a 10m by 20m rectangle (going either east/west or north/south). It also requires that the rectangle be completely covered in oil, otherwise the product is contaminated by pure ocean water and thus unprofitable! Given a map of an oil slick, the oil baron would like you to compute the maximum number of scoops that may be extracted. The map is an NxN grid where each cell represents a 10m square of water, and each cell is marked as either being covered in oil or pure water.

Input

The input starts with an integer K (1 <= K <= 100) indicating the number of cases. Each case starts with an integer N (1 <= N <= 600) indicating the size of the square grid. Each of the following N lines contains N characters that represent the cells of a row in the grid. A character of '#' represents an oily cell, and a character of '.' represents a pure water cell.

Output

For each case, one line should be produced, formatted exactly as follows: "Case X: M" where X is the case number (starting from 1) and M is the maximum number of scoops of oil that may be extracted.

Sample Input

1
6
......
.##...
.##...
....#.
....##
......

Sample Output

Case 1: 3

題目大意:

有一個地圖,' . '代表水,' # ' 代表油。每個單元格是10*10的,現用一個'.'或'#'表示,現有10*20的勺子可以提取出水上漂浮的油,問最多可以提取幾勺的油; 每次提取的時候勺子放的位置都要是油,不然就被海水汙染而沒有價值了。

解題報告:

   建模:用模板每次恰好覆蓋相鄰的兩個#,同一個點不能重複覆蓋,求最大覆蓋次數。

  建圖:這題有兩種建圖方式。一種是奇偶建圖,即(i+j)的奇偶數來建圖,vis1表示左側集合,vis2表示右側。因為木板能且僅能只能放在(i+j)%2==0 和 (i+j)%2==1這兩個相鄰的位置上,所以我們這麼去分集合。然後找匹配就可以了。

             第二種建圖方式就是如果是'#'那就++cnt,就是都用同一套體系來給‘#’標號,這樣最後匈牙利搞完之後答案/2即可。

下面分別給出程式碼。

建圖方式1的AC程式碼:

#include<bits/stdc++.h>
using namespace std;
int n,ans;
int vis1[605][605],vis2[605][605],line[605][605];
bool used[605*605];
char maze[605][605];
int tot1,tot2;
int nxt[605*605];
bool find(int x) {
	for(int i = 1; i<=tot2; i++) {
		if(line[x][i] && !used[i]) {
			used[i]=1;
			if(nxt[i] == 0 || find(nxt[i])) {
				nxt[i] = x;
				return 1;
			}
		}
	}
	return 0 ;
}
int match() {
	int sum = 0;
	memset(nxt,0,sizeof nxt);
	for(int i = 1; i<=tot1; i++) {
		memset(used,0,sizeof used);
		if(find(i)) sum++;
	}
	return sum;
}
int main() 
{
	int iCase = 0,t=0;
	scanf("%d",&t);
	while(t--) {
		tot1 = tot2 = 0;
		scanf("%d",&n);
		memset(vis1,0,sizeof vis1);
		memset(vis2,0,sizeof vis2);
		memset(line,0,sizeof line);
		for(int i = 1; i<=n; i++) {
			scanf("%s",maze[i]+1);
		}
		for(int i = 1; i<=n; i++) {
			for(int j = 1; j<=n; j++) {
				if(maze[i][j] == '#') {
					if((i+j)&1) vis2[i][j] = ++tot2;
					else vis1[i][j] = ++tot1;
				}
			}
		}
		for(int i = 1; i<=n; i++) {
			for(int j = 1; j<=n; j++) {
				if((i+j)&1) continue;
				if(maze[i][j] == '#') {
					if(maze[i][j+1] == '#' && j+1 <= n) line[vis1[i][j]][vis2[i][j+1]]=1;
					if(maze[i][j-1] == '#' && j-1 >= 1) line[vis1[i][j]][vis2[i][j-1]]=1;
					if(maze[i+1][j] == '#' && i+1 <= n) line[vis1[i][j]][vis2[i+1][j]]=1;
					if(maze[i-1][j] == '#' && i-1 >= 1) line[vis1[i][j]][vis2[i-1][j]]=1;
				}
			}
		}
		
		printf("Case %d: %d\n",++iCase,match());
	}

	return 0 ;
}

建圖方式2的AC程式碼:

#include<bits/stdc++.h>
using namespace std;
int n,ans;
int vis[605][605],line[605][605];
bool used[605*605];
char maze[605][605];
int tot;
int nxt[605*605];
bool find(int x) {
	for(int i = 1; i<=tot; i++) {
		if(line[x][i] && !used[i]) {
			used[i]=1;
			if(nxt[i] == 0 || find(nxt[i])) {
				nxt[i] = x;
				return 1;
			}
		}
	}
	return 0 ;
}
int match() {
	int sum = 0;
	memset(nxt,0,sizeof nxt);
	for(int i = 1; i<=tot; i++) {
		memset(used,0,sizeof used);
		if(find(i)) sum++;
	}
	return sum;
}
int main() 
{
	int iCase = 0,t=0;
	scanf("%d",&t);
	while(t--) {
//		tot1 = tot2 = 0;
		tot=0;
		scanf("%d",&n);
		memset(vis,0,sizeof vis);
		memset(line,0,sizeof line);
		for(int i = 1; i<=n; i++) {
			scanf("%s",maze[i]+1);
		}
		for(int i = 1; i<=n; i++) {
			for(int j = 1; j<=n; j++) {
				if(maze[i][j] == '#') {
					vis[i][j] = ++tot;
				}
			}
		}
		for(int i = 1; i<=n; i++) {
			for(int j = 1; j<=n; j++) {
				if(maze[i][j] == '#') {
					if(maze[i][j+1] == '#' && j+1 <= n) line[vis[i][j]][vis[i][j+1]]=1;
					if(maze[i][j-1] == '#' && j-1 >= 1) line[vis[i][j]][vis[i][j-1]]=1;
					if(maze[i+1][j] == '#' && i+1 <= n) line[vis[i][j]][vis[i+1][j]]=1;
					if(maze[i-1][j] == '#' && i-1 >= 1) line[vis[i][j]][vis[i-1][j]]=1;
				}
			}
		}
		printf("Case %d: %d\n",++iCase,match()/2);
	}

	return 0 ;
}

總結:

   再好好想想建圖!和POJ - 2226這個最小點覆蓋的題比較一下,也是寫過部落格的。這倆題還是有共同之處的。