1. 程式人生 > >HDU2289 Cup 【二分】求圓臺體積

HDU2289 Cup 【二分】求圓臺體積

Cup

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 11390    Accepted Submission(s): 3500

Problem Description

The WHU ACM Team has a big cup, with which every member drinks water. Now, we know the volume of the water in the cup, can you tell us it height? 

The radius of the cup's top and bottom circle is known, the cup's height is also known.

Input

The input consists of several test cases. The first line of input contains an integer T, indicating the num of test cases.
Each test case is on a single line, and it consists of four floating point numbers: r, R, H, V, representing the bottom radius, the top radius, the height and the volume of the hot water.

Technical Specification

1. T ≤ 20.
2. 1 ≤ r, R, H ≤ 100; 0 ≤ V ≤ 1000,000,000.
3. r ≤ R.
4. r, R, H, V are separated by ONE whitespace.
5. There is NO empty line between two neighboring cases.

Output

For each test case, output the height of hot water on a single line. Please round it to six fractional digits.

Sample Input

1 100 100 100 3141562

Sample Output

99.999024

Source

The 4th Baidu Cup final

Recommend

lcy

 題目分析:給你一個倒置的圓臺(上圓半徑R>=下圓半徑r),給你一定體積的水,問將水倒入圓臺後,水的高度。

如下圖
                

如右圖設裝得水高為h1,則此時上圓半徑

r1= r +  r2 

在三角形ABC中由三角形相似得

\frac{h1}{h}=\frac{r2}{r}

r1=r+\frac{r*h1}{h}                                                   

由圓臺的體積公式可得:

V=\frac{1}{3}*PI*h1*(r1*r1+r*r+r1*r)

接著二分h可得解
 

import java.util.*;
import java.math.*;

public class Main{
	static int maxn=(int)2e7+10;
	static double EPS=1e-8;
	static double r,R,H,V;
	static double PI=Math.acos(-1);
	
	static boolean check(double mid) {
		double r1=r+mid*(R-r)/H;//當前水面半徑
		double volume=PI*(r*r+r1*r+r1*r1)*mid/3.0;//求水的體積
		if(volume<V)
			return true;
		return false;
	}
	public static void main(String[] args) {
		Scanner cin=new Scanner(System.in);
		int T=cin.nextInt();
		int ca=1;
		while((T--)!=0) {
			r=cin.nextDouble();
			R=cin.nextDouble();
			H=cin.nextDouble();
			V=cin.nextDouble();
			double left=0,right=H;
			while(left<=right) {
				if(right-left<EPS)	break;
				double mid=(left+right)/2.0;
				if(check(mid))
					left=mid;
				else
					right=mid;
			}
			System.out.println(String.format("%.6f", right));
		}
		cin.close();
	}
}