【HDU2601】An easy problem(思維)
阿新 • • 發佈:2018-11-10
An easy problemTime Limit: 6000/3000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 10693 Accepted Submission(s): 2728 Problem Description When Teddy was a child , he was always thinking about some simple math problems ,such as “What it’s 1 cup of water plus 1 pile of dough ..” , “100 yuan buy 100 pig” .etc..One day Teddy met a old man in his dream , in that dream the man whose name was“RuLai” gave Teddy a problem : Given an N , can you calculate how many ways to write N as i * j + i + j (0 < i <= j) ? Teddy found the answer when N was less than 10…but if N get bigger , he found it was too difficult for him to solve. Well , you clever ACMers ,could you help little Teddy to solve this problem and let him have a good dream ?
Input The first line contain a T(T <= 2000) . followed by T lines ,each line contain an integer N (0<=N <= 1010).
Output For each case, output the number of ways in one line.
Sample Input 2 1 3
Sample Output 0 1
Author Teddy
|
【題意】
在正整數範圍內,找到一個i和j滿足 i * j + i + j=N,輸出有多少對這樣的i和j。
【解題思路】
因為i*j+i+j+1=(i+1)*(j+1) 所以(N+1)=(i+1)*(j+1)。因為i是在正整數範圍內,所以i+1在>=2的範圍,所以,只需查詢2到sqrt(N+1)中有多少個數能使N+1被整除。
【程式碼】
#include<bits/stdc++.h>
using namespace std;
typedef long long LL;
int main()
{
int T;
scanf("%d",&T);
while(T--)
{
LL n,ans=0;
scanf("%lld",&n);
for(int i=2;i<=sqrt(n+1);i++)
{
if((n+1)%i==0)ans++;
}
printf("%lld\n",ans);
}
return 0;
}