1. 程式人生 > >【ZOJ2042】Divisibility(dp)

【ZOJ2042】Divisibility(dp)

題目連結


Divisibility


Time Limit: 2 Seconds      Memory Limit: 65536 KB


Consider an arbitrary sequence of integers. One can place + or - operators between integers in the sequence, thus deriving different arithmetical expressions that evaluate to different values. Let us, for example, take the sequence: 17, 5, -21, 15. There are eight possible expressions:

17 + 5 + -21 + 15 = 16 
17 + 5 + -21 - 15 = -14 
17 + 5 - -21 + 15 = 58 
17 + 5 - -21 - 15 = 28 
17 - 5 + -21 + 15 = 6 
17 - 5 + -21 - 15 = -24 
17 - 5 - -21 + 15 = 48 
17 - 5 - -21 - 15 = 18 

We call the sequence of integers divisible by K if + or - operators can be placed between integers in the sequence in such way that resulting value is divisible by K. In the above example, the sequence is divisible by 7 (17+5+-21-15=-14) but is not divisible by 5.

You are to write a program that will determine divisibility of sequence of integers.


Input

The first line of the input contains two integers, N and K (1 <= N <= 10000, 2 <= K <= 100) separated by a space. 

The second line contains a sequence of N integers separated by spaces. Each integer is not greater than 10000 by it's absolute value.


Output

Write to the output file the word "Divisible" if given sequence of integers is divisible by K or "Not divisible" if it's not.


This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.


Sample Input

2

4 7
17 5 -21 15

4 5
17 5 -21 15


Sample Output

Divisible 

Not divisible

 

【題意】

給定n個數,中間可以新增“+”或“-”,判斷這n個數的組合是否能被k整除。

【解題思路】

dp[i][j]:前i個數模k的餘數為j。

因為一個數模k後只可能是0-k-1,所以寫一個for迴圈,如果前i-1個數的餘數j存在的話,再加上這次的num[i],當然如果是減的話需要加k避免出現負數,所以最後只需要判斷前n個數餘數為0的狀態是否存在,若存在則輸出Divisible。

【程式碼】

#include<bits/stdc++.h>
using namespace std;
int dp[10005][100],num[10005];
int main()
{
    int T;
    while(~scanf("%d",&T))
    {
        while(T--)
        {
            memset(dp,0,sizeof(dp));
            int n,k,x;
            scanf("%d%d",&n,&k);
            for(int i=0;i<n;i++)
            {
                scanf("%d",&x);
                if(x>0)num[i]=x%k;
                else num[i]=((-x)%k);
            }
            dp[0][num[0]]=1;
            for(int i=1;i<n;i++)
            {
                for(int j=0;j<k;j++)
                {
                    if(dp[i-1][j])
                    {
                        dp[i][(j+num[i])%k]=1;
                        dp[i][(j-num[i]+k)%k]=1;
                    }
                }
            }
            if(dp[n-1][0])printf("Divisible\n");
            else printf("Not divisible\n");
            if(T)printf("\n");
        }
    }
    return 0;
}