1. 程式人生 > >poj3094-Quicksum

poj3094-Quicksum

A checksum is an algorithm that scans a packet of data and returns a single number. The idea is that if the packet is changed, the checksum will also change, so checksums are often used for detecting transmission errors, validating document contents, and in many other situations where it is necessary to detect undesirable changes in data.

For this problem, you will implement a checksum algorithm called Quicksum. A Quicksum packet allows only uppercase letters and spaces. It always begins and ends with an uppercase letter. Otherwise, spaces and letters can occur in any combination, including consecutive spaces.

A Quicksum is the sum of the products of each character's position in the packet times the character's value. A space has a value of zero, while letters have a value equal to their position in the alphabet. So, A=1, B=2, etc., through Z=26. Here are example Quicksum calculations for the packets "ACM" and "MID CENTRAL":

 ACM: 1*1  + 2*3 + 3*13 = 46

MID CENTRAL: 1*13 + 2*9 + 3*4 + 4*0 + 5*3 + 6*5 + 7*14 + 8*20 + 9*18 + 10*1 + 11*12 = 650

Input

The input consists of one or more packets followed by a line containing only # that signals the end of the input. Each packet is on a line by itself, does not begin or end with a space, and contains from 1 to 255 characters.

Output

For each packet, output its Quicksum on a separate line in the output.

Sample Input

ACM

MID CENTRAL

REGIONAL PROGRAMMING CONTEST

ACN

A C M

ABC

BBC

#

Sample Output

46

650

4690

49

75

14

15

題意:輸入一串小於255的字串,寫一個演算法,使其可以輸出一個指定的數值,數值等於字元所在的位置*該字元代表的數,‘A’為1,‘B’為2...‘Z’為26,以‘#’結束輸出,字串只有大寫字母和空格,空格可以是連續的。

1.確定輸入格式,空格不代表結束以gets(a)輸入字串

2.當a[0]為‘#’時結束while迴圈

3.主要程式碼,以n記錄當前字元的位置,sum記錄當前字元的和

3.當a[i]為空格時,n++,sum不變,當a[i]為字元時,sum+=n*(a[i]-'A'+1)

4.當字串結束後,輸出sum的值

5.下次迴圈開始時,重置sum和n的值

其程式碼如下:

#include<cstdio>
using namespace std;
int main()
{
    char a[300];
    int n, sum;
    while(gets(a))
    {
        sum = 0;
        n = 1;
        if(a[0]=='#')
            break;
        for(int i = 0; a[i] != '\0'; i++)
        {
            if(a[i] == ' ')
            {
                n++;
                continue;
            }
            if(a[i] >='A' && a[i] <= 'Z')
            {
                sum += n*(a[i] - 'A'+1);
                n++;
            }
        }
        printf("%d\n",sum);
    }
    return 0;
}