1. 程式人生 > >HDU-1325-Is It A Tree?(並查集)

HDU-1325-Is It A Tree?(並查集)

Problem Description

A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties.
There is exactly one node, called the root, to which no directed edges point.

Every node except the root has exactly one edge pointing to it.

There is a unique sequence of directed edges from the root to each node.

For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.

 

In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

InputThe input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.
OutputFor each test case display the line ``Case k is a tree." or the line ``Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).
Sample Input
6 8 5 3 5 2 6 4
5 6 0 0
8 1 7 3 6 2 8 9 7 5
7 4 7 8 7 6 0 0
3 8 6 8 6 4
5 3 5 6 5 2 0 0
-1 -1
Sample Output
Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.


思路:

判斷有向圖是否為有向樹的關鍵:1.連通圖(只有一個根節點) 2.無環 3.每個節點入度為1(根節點為0)。

也就是說,1.最後只有一個集合 2.合併的時候不能合併一個集合的兩個節點 3.合併的時候子節點入度為0(子節點為根節點或子節點還未併入樹)。

坑點:

1.這個題如果有一個入度為1的節點加一個父節點,雖然程式碼上改子節點的編碼還是一個,但實際圖上已經有兩個父節點了!所以必須單獨判斷一下入度是否已經為1!

2.這個題沒給資料範圍,開1005就夠。

3.節點合併方向要注意一下,是x是y的父節點。

玄學:

用C++編譯時,flag=0放在pre[]初始化之間就會WA。我也是醉了。

紀念一下WA15次的題T^T

 


 

#include<cstdio>
#include<cstring>
using namespace std;

int pre[1005];
int mark[1005];
int flag;

int find(int x){
    while(pre[x]!=x){
        int r=pre[x];
        pre[x]=pre[r];
        x=r;
    }
    return x;
}

void merge(int x,int y){
    int fx=find(x);
    int fy=find(y);
    if(fy!=fx) pre[fy]=fx;//注意 
}

int main(){
    int x,y;
    int no=1;
    while(1){
    
        memset(mark,0,sizeof(mark));
        for(int i=1;i<=1005;i++)
           pre[i]=i;
        flag=0;
        
        while(scanf("%d%d",&x,&y)){        
            if(x<0&&y<0) return 0;
            if(x==0&&y==0) break; 
            if(find(x)==find(y)||find(y)!=y) flag=1;//兩個判斷條件缺一不可 
            else merge(x,y);
            mark[x]=1,mark[y]=1;
          }
          
        int cnt=0;
        for(int i=1;i<=1005;i++)
            if(mark[i]&&find(i)==i) cnt++;                
        if(cnt>1) flag=1;
        if(flag) printf("Case %d is not a tree.\n",no++);
        else printf("Case %d is a tree.\n",no++);    
    }
    
    return 0;
}