1. 程式人生 > >E - Cheapest Palindrome

E - Cheapest Palindrome

Keeping track of all the cows can be a tricky task so Farmer John has installed a system to automate it. He has installed on each cow an electronic ID tag that the system will read as the cows pass by a scanner. Each ID tag's contents are currently a single string with length M (1 ≤ M

 ≤ 2,000) characters drawn from an alphabet of N (1 ≤ N ≤ 26) different symbols (namely, the lower-case roman alphabet).

Cows, being the mischievous creatures they are, sometimes try to spoof the system by walking backwards. While a cow whose ID is "abcba" would read the same no matter which direction the she walks, a cow with the ID "abcb" can potentially register as two different IDs ("abcb" and "bcba").

FJ would like to change the cows's ID tags so they read the same no matter which direction the cow walks by. For example, "abcb" can be changed by adding "a" at the end to form "abcba" so that the ID is palindromic (reads the same forwards and backwards). Some other ways to change the ID to be palindromic are include adding the three letters "bcb" to the begining to yield the ID "bcbabcb" or removing the letter "a" to yield the ID "bcb". One can add or remove characters at any location in the string yielding a string longer or shorter than the original string.

Unfortunately as the ID tags are electronic, each character insertion or deletion has a cost (0 ≤ cost ≤ 10,000) which varies depending on exactly which character value to be added or deleted. Given the content of a cow's ID tag and the cost of inserting or deleting each of the alphabet's characters, find the minimum cost to change the ID tag so it satisfies FJ's requirements. An empty ID tag is considered to satisfy the requirements of reading the same forward and backward. Only letters with associated costs can be added to a string.

Input

Line 1: Two space-separated integers: N and M 
Line 2: This line contains exactly M characters which constitute the initial ID string 
Lines 3.. N+2: Each line contains three space-separated entities: a character of the input alphabet and two integers which are respectively the cost of adding and deleting that character.

Output

Line 1: A single line with a single integer that is the minimum cost to change the given name tag.

Sample Input

3 4
abcb
a 1000 1100
b 350 700
c 200 800

Sample Output

900

Hint

If we insert an "a" on the end to get "abcba", the cost would be 1000. If we delete the "a" on the beginning to get "bcb", the cost would be 1100. If we insert "bcb" at the begining of the string, the cost would be 350 + 200 + 350 = 900, which is the minimum.

題意:給定一個m長的字串,共有n種字母組成,可以通過刪除或者新增其中任意字母使其變為迴文串,每個字母都附帶一個新增的價值和去除的價值,為使這個字串變為迴文串,求實現其為迴文串的最小价值和。

思路:因為刪除或者新增同一個字母本質上得到的是同樣的效果,所以價值取二者中較小的一個就可以,然後用dp[i][j],即從i到j區間為迴文串需要的最小的價值和,當s[i]==s[j]時,對於i,j來說已經是迴文串了,所以dp[i][j]=dp[i+1][j-1],最小价值為比這個區間小的區間的所需價值,當不滿足s[i]=s[j]時,dp[i][j]=min(dp[i+1][j]+w[i],dp[i][j-1]+w[j]),即i到j這個區間不為迴文串,要使其為迴文串,只能是以上兩個區間區中的一個,取其中最小值。程式碼中的k,i迴圈是為了控制產生所有的區間段,如0-1,1-2... ; 0-2,1-3..; 0-3,1-4...;之類的。

 

#include <iostream>
#include <cstring>
using namespace std;
const int N = 200;
const int M = 2500;
int add[N];
int dp[M][M];
int main()
{
    int n,m;
    string s;
    cin>>n>>m;
    cin>>s;
    char c;
    int x,y;
    for(int i=0; i<n; i++)
    {
        cin>>c>>x>>y;
        add[c]=min(x,y);

    }
    memset(dp,0,sizeof(dp));
    for(int k=1; k<m; k++)
    {
        for(int i=0,j=k; j<m; i++,j++)
        {
            dp[i][j]=0x3f3f3f3f;
            if(s[i]==s[j])
                dp[i][j]=dp[i+1][j-1];
            else
            {
                dp[i][j]=min(dp[i+1][j] + add[s[i]],dp[i][j]);
                dp[i][j]=min(dp[i][j-1] + add[s[j]],dp[i][j]);

            }
            //cout<<dp[i][j]<<endl;
        }
    }
    cout<<dp[0][m-1]<<endl;

    return 0;
}