PAT 1054 The Dominant Color (20 分)
1054 The Dominant Color (20 分)
Behind the scenes in the computer’s memory, color is always talked about as a series of 24 bits of information for each pixel. In an image, the color with the largest proportional area is called the dominant color. A strictly dominant color takes more than half of the total area. Now given an image of resolution M by N (for example, 800×600), you are supposed to point out the strictly dominant color.
Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive numbers: M (≤800) and N (≤600) which are the resolutions of the image. Then N lines follow, each contains M digital colors in the range [0,
). It is guaranteed that the strictly dominant color exists for each input image. All the numbers in a line are separated by a space.
Output Specification:
For each test case, simply print the dominant color in a line.
Sample Input:
5 3
0 0 255 16777215 24
24 24 0 0 24
24 0 24 24 24
Sample Output:
24
解析
Dominant Color是指出現超過一半的顏色。但是其實只用統計出現次數最多即可。
選擇一組元素裡出現次數最多的元素。
建立一個map對映,從元素-> 出現次數即可。
Code:
#include<unordered_map>
#include<algorithm>
#include<cstdio>
#include<iostream>
#include<utility>
using namespace std;
int main()
{
int N, M;
scanf("%d %d", &N, &M);
unordered_map<int, int> dominant;
for (int i = 0; i < M; i++) {
int input;
for (int j = 0; j < N; j++) {
scanf("%d", &input);
dominant[input]++;
}
}
pair<int, int> max{-1,-1};
for (auto x : dominant) {
if (max.second < x.second) {
max.first = x.first;
max.second = x.second;
}
}
printf("%d", max.first);
}