POJ3087 Shuffle'm Up(模擬)
A common pastime for poker players at a poker table is to shuffle stacks of chips. Shuffling chips is performed by starting with two stacks of poker chips, S1 and S2, each stack containing C chips. Each stack may contain chips of several different colors.
The actual shuffle operation is performed by interleaving a chip from S1
The single resultant stack, S12, contains 2 * C chips. The bottommost chip of S12 is the bottommost chip from S2. On top of that chip, is the bottommost chip from S1. The interleaving process continues taking the 2nd chip from the bottom of S2
After the shuffle operation, S12 is split into 2 new stacks by taking the bottommost C chips from S12
For this problem, you will write a program to determine if a particular resultant stack S12 can be formed by shuffling two stacks some number of times.
Input
The first line of input contains a single integer N, (1 ≤ N ≤ 1000) which is the number of datasets that follow.
Each dataset consists of four lines of input. The first line of a dataset specifies an integer C, (1 ≤ C ≤ 100) which is the number of chips in each initial stack (S1and S2). The second line of each dataset specifies the colors of each of the C chips in stack S1, starting with the bottommost chip. The third line of each dataset specifies the colors of each of the C chips in stack S2 starting with the bottommost chip. Colors are expressed as a single uppercase letter (A through H). There are no blanks or separators between the chip colors. The fourth line of each dataset contains 2 * C uppercase letters (A through H), representing the colors of the desired result of the shuffling of S1 and S2 zero or more times. The bottommost chip’s color is specified first.
Output
Output for each dataset consists of a single line that displays the dataset number (1 though N), a space, and an integer value which is the minimum number of shuffle operations required to get the desired resultant stack. If the desired result can not be reached using the input for the dataset, display the value negative 1 (−1) for the number of shuffle operations.
Sample Input
2 4 AHAH HAHA HHAAAAHH 3 CDE CDE EEDDCC
Sample Output
1 2 2 -1
題意:洗牌。有兩坨一樣數量n的牌s1,s2.先給出兩坨牌的數量n,然後按從底向上的順序給出兩坨牌,每張牌只有大寫字母A~H的字串組成且中間沒有空格,再給出目標字串s3。問洗多少次牌能洗成s3那樣。洗牌的步驟如下:
1.如圖所示把s1,s2放在一起
2.把放在一起的這2n張牌,上面n張重新給s1,下面n張給s2。
解題思路:
把洗牌步驟寫出來以後就可以看出來不斷迴圈洗牌,如果出現目標狀態則輸出結果結束迴圈,如果出現之前出現過的狀態但不是目標狀態,說明進入了一個死迴圈,輸出-1,所以此時用map來記錄一下。
AC程式碼:
#include<cstdio>
#include<iostream>
#include<cstring>
#include<map>
using namespace std;
char s1[150],s2[150],s3[150];
int main()
{
int tt=1,t,n;
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
scanf("%s",s1);
scanf("%s",s2);
scanf("%s",s3);
map<string,int> book;
int step=0;
while(1)
{
char s[310];
int pos=0;
for(int i=0;i<n;i++)
{
s[pos++]=s2[i];
s[pos++]=s1[i];
}
s[pos]='\0';
step++;
if(strcmp(s,s3)==0)
{
printf("%d %d\n",tt++,step);
break;
}
if(book[s]==1&&strcmp(s,s3))
{
printf("%d -1\n",tt++);
break;
}
book[s]=1;
for(int i=0;i<n;i++)
{
s1[i]=s[i];
}
s1[n]='\0';
for(int i=n,j=0;i<2*n;i++,j++)
{
s2[j]=s[i];
}
s2[n]='\0';
}
}
return 0;
}