【POJ】3620Avoid The Lakes(求聯通塊的最大值)
阿新 • • 發佈:2018-11-26
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 9009 | Accepted: 4737 |
Description
Farmer John's farm was flooded in the most recent storm, a fact only aggravated by the information that his cows are deathly afraid of water. His insurance agency will only repay him, however, an amount depending on the size of the largest "lake" on his farm.
The farm is represented as a rectangular grid with N
Input
* Line 1: Three space-separated integers: N, M, and K
* Lines 2..K+1: Line i+1 describes one submerged location with two space separated integers that are its row and column: R and C
Output
* Line 1: The number of cells that the largest lake contains.
Sample Input
3 4 5 3 2 2 2 3 1 2 3 1 1
Sample Output
4
Source
題目大意:給出一個N*M的圖,其中還有K個點是有水珠的,問你這這水珠組成的最大聯通塊中有多少水珠。
思路:DFS搜尋聯通塊,判斷好邊界條件,儲存最大值,問題不大。。。、
程式碼:
#include<iostream>
#include<cstring>
#include<string>
#include<cstdio>
#define maxn 1001
using namespace std;
int R,C,K;
int cnt,ans;
char mp[maxn][maxn];
void dfs(int x,int y)
{
if(x<1||x>R||y<1||y>C||mp[x][y]==0)
return ;
cnt++;
mp[x][y]=0;
dfs(x+1,y);
dfs(x,y+1);
dfs(x-1,y);
dfs(x,y-1);
}
int main()
{
while(scanf("%d%d%d",&R,&C,&K)==3)
{
for(int i=1; i<=R; i++)
for(int j=1; j<=C; j++)
mp[i][j]=0;
while(K--)
{
int i,j;
scanf("%d%d",&i,&j);
mp[i][j]=1;
}
ans=0;
for(int i=1; i<=R; i++)
for(int j=1; j<=C; j++)
if(mp[i][j]==1)
{
cnt=0;
dfs(i,j);
ans=max(ans,cnt);
}
printf("%d\n",ans);
}
return 0;
}