1. 程式人生 > >dfs HDU 1045

dfs HDU 1045

Problem Description

Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall. 

A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening. 

Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets. 

The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through. 

The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways. 



Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration. 

 

 

Input

The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The next n lines each describe one row of the map, with a '.' indicating an open space and an uppercase 'X' indicating a wall. There are no spaces in the input file. 

 

 

Output

For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.

 

Sample Input
4
.X..
....
XX..
....
2
XX
.X
3
.X.
X.X
.X.
3
...
.XX
.XX
4
....
....
....
....
0
 

Sample Output
5
1
5
2
4

 

 

 

題意:

        給你一個N*N的棋盤,棋盤中有空白格和牆’X’,現在要你在空白格上放大炮,要求任意兩個大炮不能在同行或者同列,除非他們之間有一個’X’牆.問你最多能放幾門大炮.。

程式碼1:

/*

用DFS對每個空格做兩種選擇(放或不放)即可,假設我們當前在r,c位置放了大炮,那麼這一步我們還要把從r,c位置往4個方向擴充套件的所有格子都標記上,然後才是下一步選擇。

        對於這種情況,我們應該給所有放大炮的格子定序.即我們假設我們是從上到下,從左到右來放大炮的.所以我們首先列舉第一個大炮應該放的位置,確定了首位後,我們在從該位置之後的所有位置中選出第二個應該放大炮的位置….直到我們到達右下角.(定序)


*/
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
const int maxn=10;
int dr[]={-1,1,0,0};
int dc[]={0,0,-1,1};
char map[maxn][maxn];
int vis[maxn][maxn];
int n;
int ans;//解
void dfs(int pos,int num)//pos是當前位置,num是之前已經放了幾個大炮
{
    int r=pos/n, c=pos%n;
    if(map[r][c]=='X') return;
    if(vis[r][c]==1) return;
    int pre_vis[maxn][maxn];
    for(int i=0;i<n;i++)
    for(int j=0;j<n;j++)
        pre_vis[i][j]=vis[i][j];//儲存下當前的狀態,用於回溯
    vis[r][c]=1;//當前位置標記(放大炮)
    ans = max(ans,num+1);
    for(int d=0;d<4;d++)//從當前方向往4個方向走,遇到強就停下來,把所有空格都標記上
    {
        int nr=r, nc=c;
        while(1)
        {
            nr=nr+dr[d], nc=nc+dc[d];
            if(nr<0||nr>=n||nc<0||nc>=n||map[nr][nc]=='X') break;
            vis[nr][nc]=1;
        }
    }
    for(int i=pos+1;i<n*n;i++) //定序,選取下一個位置放大炮
        dfs(i,num+1);
    for(int i=0;i<n;i++)//回溯
    for(int j=0;j<n;j++)
        vis[i][j]=pre_vis[i][j];
}
int main()
{
    while(scanf("%d",&n)==1&&n)
    {
        ans=0;
        memset(vis,0,sizeof(vis));
        for(int i=0;i<n;i++)
            scanf("%s",map[i]);
        for(int i=0;i<n*n;i++) dfs(i,0);
        printf("%d\n",ans);
    }
}
 

方法二:

#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
const int maxn=10;
int dr[]={-1,1,0,0};
int dc[]={0,0,-1,1};
char map[maxn][maxn];
int vis[maxn][maxn];
int n;
int ans;//解
void dfs(int pos,int num)//pos是當前位置,num是之前已經放了幾個大炮
{
    if(pos==n*n) return ;  //不加這句就會出現越界錯誤
    dfs(pos+1,num);   //這個地方不放,下面考慮的是這個地方放,同時搜尋下一步要回溯。
    int r=pos/n, c=pos%n;
    if(map[r][c]=='X') return;
    if(vis[r][c]==1) return;
    int pre_vis[maxn][maxn];
    for(int i=0;i<n;i++)
    for(int j=0;j<n;j++)
        pre_vis[i][j]=vis[i][j];//儲存下當前的狀態,用於回溯
    vis[r][c]=1;
    ans = max(ans,num+1);
    for(int d=0;d<4;d++)//從當前方向往4個方向走,遇到牆就停下來
    {
        int nr=r, nc=c;
        while(1)
        {
            nr=nr+dr[d], nc=nc+dc[d];
            if(nr<0||nr>=n||nc<0||nc>=n||map[nr][nc]=='X') break;
            vis[nr][nc]=1;
        }
    }
    //for(int i=pos+1;i<n*n;i++) //定序,選取下一個位置放大炮
    dfs(pos+1,num+1);   //直接考慮相鄰的下一個格子
    for(int i=0;i<n;i++)//回溯
    for(int j=0;j<n;j++)
        vis[i][j]=pre_vis[i][j];
}
int main()
{
    while(scanf("%d",&n)==1&&n)
    {
        ans=0;
        memset(vis,0,sizeof(vis));
        for(int i=0;i<n;i++)
            scanf("%s",map[i]);
        dfs(0,0);
        printf("%d\n",ans);
    }
}