1. 程式人生 > >簡單字串比較

簡單字串比較

Problem Description
請使用字串比較函式,比較兩個字串的大小,並按要求輸出比較後的結果。字串最長不超過15個字元。
輸入兩個字串str1和str2,如果第一個字串與第二個字串相等,輸出str1=str2,如果第一個字串大於第二個字串,輸出str1>str2,如果第一個字串小於第二個字串,輸出str1 < str2。

Input
第1行為第一個字串。
第2行為第二個字串。

Output
在一行輸出比較後的結果。例如"abc"與"abc"相等,輸出為abc=abc,如果"ab"小於"abc”,輸出ab < abc。

Sample Input


ab
abc

Sample Output
ab<abc

AC程式碼:

import java.util.Scanner;

public class Main {

	public static void main(String[] args) {
		Scanner mi = new Scanner(System.in);
		String str1 = mi.nextLine();
		String str2 = mi.nextLine();
		if (str1.compareTo(str2) == 0) {
			System.out.println(str1 + "=" + str2);
		} else if (str1.compareTo(str2) > 0) {
			System.out.println(str1 + ">" + str2);
		} else {
			System.out.println(str1 + "<" + str2);
		}
		mi.close();
	}
}

——————
餘生還請多多指教!