1. 程式人生 > >ACM-ICPC北京賽區2017網路同步賽 E+F

ACM-ICPC北京賽區2017網路同步賽 E+F

目錄

E - Cats and Fish(模擬+思維)

F - Secret Poems(模擬+字串處理+蛇形填數)


E - Cats and Fish(模擬+思維)

There are many homeless cats in PKU campus. They are all happy because the students in the cat club of PKU take good care of them. Li lei is one of the members of the cat club. He loves those cats very much. Last week, he won a scholarship and he wanted to share his pleasure with cats. So he bought some really tasty fish to feed them, and watched them eating with great pleasure. At the same time, he found an interesting question:

There are m fish and n cats, and it takes ci minutes for the ith cat to eat out one fish. A cat starts to eat another fish (if it can get one) immediately after it has finished one fish. A cat never shares its fish with other cats. When there are not enough fish left, the cat which eats quicker has higher priority to get a fish than the cat which eats slower. All cats start eating at the same time. Li Lei wanted to know, after x minutes, how many fish would be left.

Input

There are no more than 20 test cases.

For each test case:

The first line contains 3 integers: above mentioned m, n and x (0 < m <= 5000, 1 <= n <= 100, 0 <= x <= 1000).

The second line contains n integers c1,c2 … cn,  ci means that it takes the ith cat ci minutes to eat out a fish ( 1<= ci <= 2000).

Output

For each test case, print 2 integers p and q, meaning that there are p complete fish(whole fish) and q incomplete fish left after x minutes.

Sample Input

2 1 1
1
8 3 5
1 3 4
4 5 1
5 4 3 2 1

Sample Output

1 0
0 1
0 3

【題意】輸入魚的數量和貓的數量以及時間,以及每隻貓吃掉一隻魚需要的時間,吃的快的在魚不夠的時候優先吃到魚,問該時間後還剩下的完整的魚和不完整的魚的數量。

【分析】定義一個結構體,存每隻貓吃魚的時間和是否在吃的狀態。然後按吃魚的時間升序排序。遍歷時間。如果當前這隻貓沒有在吃魚,就給它一條魚讓它吃,如果這個時間可以讓它吃完一條魚,那麼已經沒有吃魚了,狀態標記為沒吃。所以,對於每個時間點,只有該時間可以讓它吃完一條魚的時候才會eat標記為0,當某隻貓標記為0說明上一秒它已經吃完一條魚,就魚的數量增加。最後剩下的完整的魚的數量就是總的魚的數量減去吃掉的。遍歷每隻貓,狀態為正在吃的就是不完整的魚的數量。

【程式碼】

#include<bits/stdc++.h>
using namespace std;

struct node{
	bool eat;
	int t;
}cat[105];
bool cmp(node x,node y)
{
	return x.t<y.t;
}

int main()
{
	int m,n,x;
	while(~scanf("%d%d%d",&m,&n,&x))
	{
		for(int i=1;i<=n;i++)
		{
			scanf("%d",&cat[i].t);
			cat[i].eat=false;
		} 
		sort(cat+1,cat+1+n,cmp);
		int p=m,q=0;
		for(int i=1;i<=x;i++)
		{
			for(int j=1;j<=n;j++)
			{
				if(cat[j].eat==false && p>0)//沒有在吃並且魚還有剩餘 
				{
					p--;//分一條魚給它,並且狀態變成吃 
					cat[j].eat=true;	
				}
				if(i%cat[j].t==0)//該時間正好吃完一條魚,下一秒狀態即為false 
					cat[j].eat=false;
			}
		}
		for(int i=1;i<=n;i++)
			if(cat[i].eat==true)q++;
		cout<<p<<" "<<q<<endl;
	}
	return 0;
}

F - Secret Poems(模擬+字串處理+蛇形填數)

The Yongzheng Emperor (13 December 1678 – 8 October 1735), was the fifth emperor of the Qing dynasty of China. He was a very hard-working ruler. He cracked down on corruption and his reign was known for being despotic, efficient, and vigorous.

Yongzheng couldn’t tolerate people saying bad words about Qing or him. So he started a movement called “words prison”. “Words prison” means literary inquisition. In the famous Zhuang Tinglong Case, more than 70 people were executed in three years because of the publication of an unauthorized history of the Ming dynasty.

In short, people under Yongzheng’s reign should be very careful if they wanted to write something. So some poets wrote poems in a very odd way that only people in their friends circle could read. This kind of poems were called secret poems.

A secret poem is a N×N matrix of characters which looks like random and meaning nothing. But if you read the characters in a certain order, you will understand it. The order is shown in figure 1 below:

            figure 1                                                           figure 2

Following the order indicated by arrows, you can get “THISISAVERYGOODPOEMITHINK”, and that can mean something.

But after some time, poets found out that some Yongzheng’s secret agent called “Mr. blood dripping” could read this kind of poems too. That was dangerous. So they introduced a new order of writing poems as shown in figure 2. And they wanted to convert the old poems written in old order as figure1 into the ones in new order. Please help them.

Input

There are no more than 10 test cases.

For each test case:

The first line is an integer N( 1 <= N <= 100), indicating that a poem is a N×N matrix which consist of capital letters.

Then N lines follow, each line is an N letters string. These N lines represent a poem in old order.

Output

For each test case, convert the poem in old order into a poem in new order.

Sample Input

5
THSAD 
IIVOP 
SEOOH 
RGETI 
YMINK
2
AB
CD
4
ABCD
EFGH
IJKL
MNOP

Sample Output

THISI
POEMS
DNKIA
OIHTV
OGYRE
AB
DC
ABEI
KHLF
NPOC
MJGD

【分析】模擬題吧

【程式碼】

#include<bits/stdc++.h>
using namespace std;

const int maxn=105;
char a[maxn][maxn],b[maxn*maxn],c[maxn][maxn];

int main()
{
	int n;
	while(~scanf("%d",&n))
	{
		memset(a,0,sizeof(a));
		memset(b,0,sizeof(b));
		memset(c,0,sizeof(c));
		for(int i=0;i<n;i++)scanf("%s",a[i]);
		int nn=2*n,cnt=0;
		for(int k=0;k<nn;k++)
		{
			if(k&1)//奇數
			{
				for(int i=0;i<n;i++)
					if(a[i][k-i])b[cnt++]=a[i][k-i];
			} 
			else
			{
				for(int i=k;i>=0;i--)
					if(a[i][k-i])b[cnt++]=a[i][k-i];
			} 
		}
		int tot=0,x=0,y=0;
		c[0][0]=b[0];//這裡是c,不是a
		while(tot<n*n)//蛇形填數
		{
			while(y+1<n && !c[x][y+1])c[x][++y]=b[++tot];
			while(x+1<n && !c[x+1][y])c[++x][y]=b[++tot];
			while(x-1>=0 && !c[x-1][y])c[--x][y]=b[++tot];
			while(y-1>=0 && !c[x][y-1])c[x][--y]=b[++tot];
			if(tot==n*n-1)break;//注意減1
		}
		for(int i=0;i<n;i++)
		{
			for(int j=0;j<n;j++)
				printf("%c",c[i][j]);
			printf("\n");
		}
	}
	return 0;
} 

 

程式碼段 小部件 [Dàimǎ duàn xiǎo bùjiàn] Code section widget

[Dàimǎ duàn xiǎo bùjiàn [Dàimǎ duàn xiǎo bùjiàn] Code section widget]

Code section widget

[Dàimǎ duàn xiǎo bùjiàn]

Code section widget