1. 程式人生 > >PAT 1041 Be Unique

PAT 1041 Be Unique

 Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1,10​4​​]. The first one who bets on a unique number wins. For example, if there are 7 people betting on { 5 31 5 88 67 88 17 }, then the second one who bets on 31 wins.

Input Specification:

 Each input file contains one test case. Each case contains a line which begins with a positive integer N (≤10​5​​) and then followed by Nbets. The numbers are separated by a space.

Output Specification:

 For each test case, print the winning number in a line. If there is no winner, print None

 instead.

Sample Input 1:

7 5 31 5 88 67 88 17

Sample Output 1:

31

Sample Input 2:

5 888 666 666 888 888

Sample Output 2:

None

題意:關鍵句 "The first one who bets on a unique number wins"  ,即找出第一個不重複出現的數字

程式碼

#include<iostream>
#include<cstdio>
#include<vector>
using namespace std;
const int Max=1e4+5;
int main()
{
    int Bet[Max],N,x;
    scanf("%d",&N);
    vector<int> Mark;
    for(int i=0;i<N;i++)
    {
        scanf("%d",&x);
        if(!Bet[x])
          Mark.push_back(x);
        Bet[x]+=1;
    }
    for(int i=0;i<Mark.size();i++)
    {
        x=Mark[i];
        if(Bet[x]==1)
        {
            printf("%d",x);
            return 0;
        }
    }
    printf("None");
    return 0;
}