1. 程式人生 > >PAT 1045 Favorite Color Stripe (30)

PAT 1045 Favorite Color Stripe (30)

1045 Favorite Color Stripe (30)(30 分)

Eva is trying to make her own color stripe out of a given one. She would like to keep only her favorite colors in her favorite order by cutting off those unwanted pieces and sewing the remaining parts together to form her favorite color stripe.

It is said that a normal human eye can distinguish about less than 200 different colors, so Eva's favorite colors are limited. However the original stripe could be very long, and Eva would like to have the remaining favorite stripe with the maximum length. So she needs your help to find her the best result.

Note that the solution might not be unique, but you only have to tell her the maximum length. For example, given a stripe of colors {2 2 4 1 5 5 6 3 1 1 5 6}. If Eva's favorite colors are given in her favorite order as {2 3 1 5 6}, then she has 4 possible best solutions {2 2 1 1 1 5 6}, {2 2 1 5 5 5 6}, {2 2 1 5 5 6 6}, and {2 2 3 1 1 5 6}.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤200) which is the total number of colors involved (and hence the colors are numbered from 1 to N). Then the next line starts with a positive integer M (≤200) followed by M Eva's favorite color numbers given in her favorite order. Finally the third line starts with a positive integer L (≤10​^4​​) which is the length of the given stripe, followed by L colors on the stripe. All the numbers in a line a separated by a space.

Output Specification:

For each test case, simply print in a line the maximum length of Eva's favorite stripe.

Sample Input:

6
5 2 3 1 5 6
12 2 2 4 1 5 5 6 3 1 1 5 6

Sample Output:

7

思路:

這道題和最大公共子序列很相似,不同的是公共部分的數字可以重複出現,那麼我們就要在LCS上做一些修改,每次更新len[i][j]時都要用len[i-1][j-1]、len[i-1][j]、len[i][j-1]中的最大值,如果favourite[i-1]==given[j-1]那麼對應的len[i][j]還要再加1。

程式碼:

#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <cctype>
#include <climits>
#include <iostream>
#include <algorithm>
#include <string>
#include <vector>
#include <queue>
#include <stack>
#include <map>  
#include <set>
using namespace std;

int favorite[205] = { 0 };
int given[10005] = { 0 };
int len[205][10005] = { 0 };

int max(int a, int b, int c)
{
	return a > b ? (a > c ? a : c) : (b > c ? b : c);
}

int LCS(int row, int col)
{
	for (int i = 1; i <= row; i++)
	{
		for (int j = 1; j <= col; j++)
		{
			int maxlen = max(len[i - 1][j - 1], len[i - 1][j], len[i][j - 1]);
			len[i][j] = maxlen;
			if (favorite[i - 1] == given[j - 1])
				len[i][j]++;
		}
	}
	return len[row][col];
}

int main()
{
	int n, m, l;
	cin >> n >> m;
	for (int i = 0; i < m; i++)
		cin >> favorite[i];
	cin >> l;
	for (int i = 0; i < l; i++)
		cin >> given[i];
	cout << LCS(m, l) << endl;
	return 0;
}